Pi 3 Model B+ Octoprint Build


Good morning everyone,

I just purchased my first 3D Printer a month ago, Tevo Tornado and now my very first Raspberry PI. Prior to ordering I did not realize Model B+ wasn't truly supported for OctoPrint, only to discover once arriving at the website. I'm a bit confused as to whether or not there it a working build for the B+ model, the nightly link does not work so unsure how to proceed from here. Thank you.

Offline (Error: IOError: '[Errno 25] Inappropriate ioctl for device' @ comm.py:_readline:2417)

Your post doesn't tell us much about what kind of problems you ran in to. I know just about everyone running OctoPrint on a Pi 3B+ is using the OctoPi nightly build and having fairly good luck with it. However, the nightly build is a development version, so it may not be entirely stable at this point.

OctoPrint DOES work with the Raspberry Pi 3B+. The stable release OctoPi (version 0.14) does not. This is because OctoPi 0.14 was based on an older version of the Raspian Operating system (Raspian Jessie) which does not support the 3B+. THe nightly is based on Raspian Stretch (which is compatible with the PI 3B+).

Tell us a bit about what is going on when you try it, and we may be able to help you (starting with what version of OctoPi you downloaded, how you installed it on your SD card, and what set-up you did once installed).


Thank you John. Yes John I was only getting started with creating the SD card but wasn't sure exactly what to use but did find a working link to the nightly builds. So I have used Etcher to send the latest nightly build to the SD card. I then modified the WPA-suppliment file with my wifi credentials. When I get home tonight I will then attempt to power up and see what happens. The goal is to use the PI as my platform for 3D printing, setup a camera etc..I just received the PI last night and just wanted to make sure I was at least on the right track. Thank you for explaining the differences with the builds and how they relate to different platforms.


Let us know how it goes. If you have any problems, any bits of information you can provide may be helpful. Red light should come on steady when you power up, and the green light should flash. It can take a while to get all settled in the first time you power up, since the Pi has some "housekeeping duties" to take care of on first boot. Make sure to use the proper program when editing the octopi-wpa-supplicant.txt file. Windows WordPad (and I believe Windows NotePad) will not work. Apple's TextEdit doesn't work either (though it can be easily tweaked). If you have trouble with getting WiFi working on your Pi, check out Getting your WiFi Connection Working


I installed the official stable one and didn't work, until I got on the latest nightly build http://gnethomelinux.com/OctoPi/nightly/


Thank you John, yes I used Notepad++ as recommended form a Youtube video. Really appreciate your feedback and will post back once I have successfully flashed and hopefully accessed.


Thank you for the update robob3ar, I did grab the latest nightly build and have it all ready to go on the SD card.


Just an update, so I used the 4-11 nightly build, edited the WPA supplicant txt file to include my SSID and passcode and uncommented my country code. Could not get see the device on the network. This morning I reformated the SD card and download 4-14 nightly build and giving it another attempt. Now my SSID on my firewall uses AES only so not sure if the PI requires TKIPS or not.


So far using the very latest nightly, I have not been successful communicating through wifi. The device is powered up approx. 15 minutes now, running Angry IP Scanner I am not seeing ant new devices on my list. I have double checked the edits and everything is ok. Now sure why it will not work.


So I decided to LAN into the PI and of course that allowed a Putty connection. I did a few items, expanded to storage, re-config the Wifi settings, country locale, hostname etc..after rebooting I no longer had a red power light only a green activity light. I did have access still with the LAN to Octoprint itself thru its IP. Upon disconnecting the LAN cable the red power light came back on, still no wifi. I looked at the WPA supplicant itself, and no changes, same as I configured. Now I assume the 'VAR' directory is hidden as its referenced in the WPA supplicant but not visible in the directory. Having a LAN cable isn't really desirable but at least I know the system itself is indeed running. Not sure what to do next at this point regarding the wifi.


@DM_Cam - what are you using for a power supply for your Pi?

Can you cut and paste the block of octopi-wpa-supplicant.txt that you edited (including lines just before and just after what you edited)? You can block out the actual SSID and password.

I do not own a 3B+, so I'm hoping others on here with more knowledge will chime in.


Hi John, thanks for helping. I am actually running a DROK 24V to 5V stepdown transformer and it puts out a 4.99v on the output. I have the DROK input coming off my 24v power converter. I don't have the PI to reference cause I am at work but I know exactly what the lines of code look like in my head.

" ## WPA/WPA2 secured ( had to add the " at the beginning for this comment to show the hash tags, its not like that in the code itself)


"## Open/unsecured

And then at the bottom, the country is defaulted to the United Kingdon so I put back the hash symbol and uncommented my country. I did order a 5V, 3A power adapter today just to be sure because the transformer only supplies 2A.

country=CA # Canada

Unlike the previous file, this new wpa-supplicant file doesn't reference the SSID or passcode as "wpa-ssid" or "wpa-psk". I tried putting that in but same issue, no wifi.



Help Mr Wizard!
First, I canot inckude code blocks since they can't be imported from the RPI that I am truying to run the Octopi on dueto no desk top or edit/capture capabilities that I am aware of. ((HELP!))
I have a new (tested) RPI3B+ running the nightly (2018-04-15_2018-03-13-octopi-stretch-lite-0.15.0.zip)
I edited the correct file with my SSID and psk after uncommenting the lines.
RPI boots and I have green light activity
When I try to run http:octopi.local I get "Unable to load page"
When I run sudo ifconfig under wlan0 I get only the ethernet address but no IPA.
eth0 and wlan0 show RX packets 0 and TX packets 0
with no IPA
lo: flags+73<UP, LOOPBACK, RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1 (local loopback)
RX packets 6 bytes 600 (600.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 6 bytes 600 (600.0B)
TX errors 0 dropped 0 overruns 0 carrier 0 collissions 0
wlan0: flags=4099<UP, BROADCAST, MULTICAST> mtu 1500
ether b8:27:eb:28:80:a1 txqueneblen 1000 (Ethernet)
RX Packets 0, etc
TX Packets 0, etc

I had to type manually pardon the obvious typos but it will not connect.
PLEASE advise.
Drizzle, Drazzel, Drossle, Drone, time for zis vone to come home...


I'm not much of a Wizard with the 3B+, since I don't have one (not that I'm much of a wizard at anything). Your problem doe snot sound 3B+ related to me.

My first question: what are you using to access OctoPrint with octopi.local? You know it does not work from Windows, unless you've set up Bonjour for Windows on your PC. You need to use your Pi's IP address to access it.

From your output, it appears you are not connected to your Wifi network. I suggest you start with this thread on Getting your WiFi connection working

There is one change you should note form the thread linked above: Since you are using the nightly build, you need to edit the octopi-wpa-supplicant.txt (rather than octopi-network.txt). There are 4 lines in there that need the # comment removed. The edited section should look something like this:

## WPA/WPA2 secured


Thanks for the reply John.
I tried from Windows 10 PC as well as from another RPI3B+, same failed to load page.
I did edit the WPA/WPA2 with the correct SSID and PSK.
There was a tantalising comment in the forum where someone said they went into the /etc/network and changed a setting either from or too manual. EEEKK he didn't spell out what he did exactly. That is like saying that all you have to do to pull the engine is loosen a few bolts and wires and badabing, badabang, she's out.
I looked on my router and the only devices that show up are the Roku's I have and the computer I was searching from so I know that the RPI didn't get as far as the router.
Dude, I will gladly send you a RPI3B+. That is the current issue machine and what almost every noob (like me) will be running on. My email is jhansx@gmail.com. Send me your address in a private email and you will have one winging its way to you by tomorrow AM. I assume you have an SD card and a machine to burn the image with?
I mean it. We need your genius and you need a machine that is what we are all using. It will also help with the snarky camera stuff which always seems to be an issue some how or the other. I have like 6 3B+'s and can't think of a better use for one of them. Just put it in an original box and it's waiting for your address.
Thanks again for your help.
Be safe!
J.S.Holverson, MD KG7TXI


No joke. It's boxed and ready to go. Someone has to solve this, I think you could. At least you have a Pi 3B+ to play with.
Get me an address or send a general delivery address if you are worried I am a terrorist.
Be safe.


@Jeff_Holverson - Thanks, but seriously, I'm not the genius here. I've just read a lot from people who really know their stuff.

Instead of sending me a Pi 3B+, might I suggest you donate one to a local school's makerspace, or perhaps volunteer with a classroom teacher who is interested in exposing their kids to 3D printing? I did it for my daughter's 5th & 6th grade class and it was a lot of fun.

BTW - I edited my previous post to show what the lines in your octopi-wpa-supplicant.txt should look like. There are four lines that you have to remove the # from in front of, and the indentation should be preserved (delete JUST the #, not any of the leading spaces).


Already donated to school.
We need a solution for the RPI 3B+.
Who can handle the issue? I did the edit on the file. No joy!
All other places I look the same problem persists. Someone in the high up needs a 3 B+ to work out the patch/fix. Really like the facility of Octopi, can't be that big a deal. I'll send you the B+ then when you are done, give it to your kids school.
Have equipment need solution...


Did you work through the WiFi tips in the post I linked?
what do you get when you enter

sudo iwlist wlan0 scan

This should give you a listing of all the WiFi networks your Pi can see (whether it is connected to them or not).


Back at it and it isn't a power issue. Installed the latest build, edited the WPA-Supplicant file, same as before. Device does not connect to wifi with these nightly builds. When I run iwlist I do see all the broadcasts including mine. My setup runs AES not TKIP.

When I go into raspi-config through a LAN adapter and go to the wifi section I get a message saying "Could not communicate with wpa-supplicant" and when i hit ok the next message is "There was an error running option N2 Wifi".