Pi Camera V3/IMX Chipset Based Cameras Not Working

Another +1 for this script and install. Thanks! My camera looks great and I'm working on Timelapses now. It took about 20 minutes and a few tweaks on my end but the camera shows up great in Octo. I DID end up doing a new card and new install though and I'm still working on getting my 4" Waveshare pi screen rotated and the touch rotated to landscape aspect if anyone has any good pointers on how to do this. But the touch screen "works" in Portrait mode right now so I'm just going with it.

Just looking for some advice. Completely new to PI and coding inc SSH etc. I have purchased a Raspberry Pi 4 Model B and a HyperPixel 4.0 Square touchscreen. I was unable to get the screen working with OctoPi so I had to install the 32bit OS lite Bullseye OS with no desktop environment. I then manually installed Octoprint then installed OctoDash and they are both functioning fine.
I have a Raspberry Pi camera V3 with I have been able to get working using the libcamera commands and produced a test jpeg and a short video. Thats as far as I have got and have not been able to find a way to connect the Camera to OctoPrint. Will running this script resolve my issue? Also my only experience with coding on PI and all this has been from the forums and YT so I suspect something I have said don't make sense.
Any help appreciated.

@Andre_Rousseau, Thank you for the kind words, but I believe my script's time is done. Octopi 1.0.0 went official a few days ago, and there is a new camera stack that supports the Camera Module 3 being tested. I have not had a chance to try it myself, but I suggest you try that instead.

Feedback for the new camera-streamer based webcam stack

Good morning, is there any way to rotate the camera 90ΒΊ? I don't mean in octoprint, I mean in the camera-stream settings, would anyone know how to do it? Thanks and best regards

@ltlowe i ran your script and can't get the pi cam 3 working :frowning:

Forgot to add details sorry,

i have a Prusa MK3S+ using SimplyPrint which is octoprint based running on a raspberry pi 4 model b 3gb ram.

It shouldn't matter that i'm running SimplyPrint since the webcam doesn't show up in octoprint when connected to the octoprint UI.

the script requires OctoPi 1.0.0 as a base OS because it needs to be bullseye for camera-streamer to work. The SimplyPi image is currently still based on the buster image.

Copy and pasting this worked for me without any further issues on my Pi 3B+ with Camera module V3. Thank you so much gambiting! Trying to solve this as a new Pi and Octoprint user taught me a lot but it was becoming frustrating. I'm so glad Octoprint is fully functional now.

I am new here and reading through this thread, I'm getting lost. Let me know if I should make a new thread, but can someone please point me in the right direction as far as how to get my raspberry pi camera module 3 to work with my raspberry pi.

My current set up is a raspberry pi 3A+ with OctoPrint version 1.8.7 and OctoPi version 1.0.0. I have raspberry pi camera module 3 attached, but cannot get it to work with OctoPrint. I have read through this thread, but I don't know where I should start. Am I suppose to install a whole other operating system on the raspberry Pi? Can someone tell me where I am suppose to start, please? Thank you!

@Scrambler2612, Official support (from Raspberry Pi) for the camera V3 is available in Debian 11 (Bullseye) based operating systems. Since you have OctoPi 1.0.0 you have satisfied that requirement. You may need to be up-to-date by using sudo apt update && sudo apt upgrade.

OctoPrint, however, needs some additional software to use the camera V3 and that support is currently in testing. To use it will require a new OS image.

I suspect that "a new image" may actually mean "multiple new images". You probably could get away with "two new images" but installing the latest available now and then waiting until the testing phase is over and installing the final image but this assumes that the currently available image works for you.

You can follow the progress of the testing phase in https://github.com/OctoPrint/OctoPi-UpToDate/issues/2.

I have a USB SD card adapter which I can move from my desktop (where I download and flash new images) to my RPi (where I can move files from the previous image to the new one). If you don't have any files other than those related to OctoPrint, then making an OctoPrint backup on the old image, downloading it, and then restoring it to the new image should be sufficient. You can also use something like WinSCP to backup and restore files instead.

Thank you so much for taking the time to respond to my question. I just flashed the new image to my SD card and the camera works! The image quality is quite good too. Thank you so much!

Having now read through this thread and over on the feedback thread for the new camera streamer stack I'm a little puzzled for what to do.

I previously posted a call for help over on the Raspberry Pi forums, before checking here and realizing the issues probably isn't related to a vanilla installation. Here's my post for reference.

In summary, I've got a fresh configuration of OctoPrint install flashed using the Raspberry Pi flashing tool on the Bullseye version. I've updated and upgraded everything and things are working great including OctoDash.

So am I correct in the assessment that the only way to fix this is to flash this new, beta image? Or can I run the script from @ltlowe?

Obviously, I'd love for the fix to come as part of an incremental update rather than a complete re-deployment or making any ad hoc changes that might later complicate an update.

I think @b-morgan's post just above sets out the issue reasonably well:

The script might still work but it has been dropped in favour of the new OS image.

Unfortunately it won't ever come from an incremental update as the webcam streaming stack is not set up for this. Perhaps in the future it might be set up to be updatable, who knows - but we definitely can't change the past so you will have to flash a newer image (ie. the testing image linked) than what is available right now.

Well, kind of a bummer I guess. Probably the biggest hassle is that it's not just OctoPrint that I setup on this device. So usually a new image means setting up several other things each time which is a hassle, but I get that's the way it works right now.

Well, the new image does seem to work so that's great. I just now know I'll have to re-image here once that goes to general release.

@b-morgan - would you mind explaining how you put a new image on the Pi without taking the SD card out (if I understand correctly what you do)? My Pi is in an enclosure and permanently attached to my Prusa. Opening the enclosure is quite a hassle. Pointing at an explanation works fine for me. Thanks for your help. Hubert

@hubert.smits, I'm sorry if I gave you that impression but I don't put new images on the Pi without taking the card out. I use a USB microSD card adapter and two microSD cards.

I use the USB adapter on my desktop to write the new image. After booting the new image on the Pi. I use an OctoPrint backup to restore plugins and files related to OctoPrint. I move the adapter back to the Pi so I can copy any non-OctoPrint files from the old image to the new image.

After I'm satisfied with the new image, I use rpi-clone to make a copy of the current microSD card.

Could you use something like this to extend the microSD slot to a more convenient location?

Thanks, I understand what you are doing. And I have the SD extension arriving today - great minds think alike :slight_smile:

I'm still operating fine with the RC build of OctoPi 1.0 and the script prepared by @ltlowe

Other than presumably, full 1080p, I'm hesitant to update to the official support just yet as Github still has people complaining.

Anyone else make the switch/upgrade and is happy that they did?

I'm not sure where you got the impression that there aren't people happy with the image from the OctoPi-UpToDate GitHub. I can count the vast majority of comments in the GitHub issue being positive 'it works', with maybe a couple of issues that are unsolved. A lot of problems have been solved in that thread.

It's completely up to you whether to switch, at the end of the day you are unlikely to gain much, I was just wondering why the GitHub issue made you hesitant to do so.