Plugin disabled Octoprint


Got my Creality ender 3 for Xmas all works well, installed Octoprint onto an old RPi 2B again that all worked without issue which was great. The only issue was that Octoprint was indicating that the firmware on my printer broke the protocol with double temperature reading as and could be recitifed using this plugin. I duly installed it and for some reason the print server no longer starts up, any ideas as to why would be great, I can re install Octo print and live with the warning but it warns of failed prints, unreliability, etc so if it is needed I would prefer to have it running.

Printer: Ender 3
Pi: Rpi 2B
OS: Latest Raspian
Octoprint: 0.18.0

I have attached the Octo print log.
Octoprint.log (11.4 KB)



Hello @mlw !

What you attached is not a octoprint.log
It looks like the login of the SSH back end.

From that point you can enable safe mode (<- click me) to disable or 3rd party plugins.
Then you delete the suspicious plugin from within OctoPirnt

As Ewald_Ikemann already stated it's a printout of the ssh session. I guess you intended to include the log 'manually' but unfortunately nano didn't output to stdout.

It might have worked if, instead of nano ~/.octoprint/logs/octoprint.log you'd done a
cat ~/.octoprint/logs/octoprint.log


Thanks for the response.

I have since unplugged the RPi from the printer and let it power up separately, the server then started working, I re plugged it in and all now seems well so no idea what the original issue was.