Plugin Repository always says Unavailable

Hey all, I recently had to reinstall Octoprint because the SD card slot somehow got bumped slightly which caused it to be inoperable. I purchased a new 4B and reinstalled as before, and started to attempt to install the plugins I had previously used on the damaged Pi, but every time I attempt to connect to the repository I get an error message saying "Sadly the repository is currently not available. Is your OctoPrint installation connected to the internet?" It is connected to the internet when I try to connect, because I've been attempting to download before starting a print, and when I get that message I just go ahead and start the print thinking I'll check back later and maybe have better luck, but I've never been able to actually connect. Is this a common issue, or is something else preventing me from connecting? Any help would be greatly appreciated.

Hello @rsadler !

Can you please share the octoprint.log here in the forum? If it's too long, you can zip it. (3.3 MB)

Are you sure the RasPi has internet connection?

Another thing: Please do not restart the Pi by just removing the power. Sooner or later you will end up with a corrupted filesystem on the SD card.

Yes it has an internet connection, it's connected wirelessly to my router, and the Pi starts when the printer starts via smart plug so it's always running when the printer is on, and I still get the connection error message. So I shouldn't let the Pi start and shut down this way?

Please go to the OctoPrint settings and check for connectivity:

The hostname connects fine, but host IP and port aren't connecting for some reason

So it seems that your Pi has no Internet connection.

Do you have a repeater in your local network to which the Pi is connected to?
This can produce some issues.

Maybe there are some restrictions setup in the router.

I have a repeater between my Ring doorbell and the router, but my previous 4B Pi that i just replaced due to a broken SD card holder, was working ok with the same setup, which included the same repeater.

You know you can just use a thumbdrive instead of an sd card, right?
If the pi has run a halfway actual version of raspbian it should work out of the box, if not you might have to boot a firmware update once.
The sd card just needs to work for a few seconds and then never again.

No I didn't know that. I've already replaced the Pi 4B and installed Octoprint on it and have been using it ok, except apparently It's not connected to the internet, as I found out while trying to download my plugins from a previous install, but not sure I don't have connectivity. During setup I connected to my wifi, and set it to auto login when I boot up, :frowning:

I decided to look through the config files on the SD card, and noticed I had I commented United Kingdom instead of United States when enabling WiFi. I saved and rebooted but still no connectivity, I’m wondering if I should just do a wipe and clean install over again.

If you can resolve the hostname but can't ping, then it might just be that for some reason that's getting filtered somewhere on your network and your Pi actually DOES have internet connectivity.

Try instead, then, and if neither works disable the connectivity check and test whether you can access the plugin repository. If so something somewhere on your network or ISP filters external DNS servers (which personally would make me go nuts).

1 Like

OMG thank you so much Gina! I was about to start over and reinstall everything, because my previous install on the exact same model Pi worked fine with no issues for quite a long time. The first option you suggested, worked instantly! Thanks again!!