Plugins not completing install

I'm running OctoPrint on a RPi 3B+. I've installed ~12 plug-ins previously without issue. Recently, OctoPrint is unable to complete the installation of other plugins. It appears to complete w/ a "Done" displayed but below is what I see in the popup. Notice the Unknown where it would normally display the plugin that was installed. Overall, the RPi seems to be sluggish and the connection with the printer seems intermittent as well. Any ideas how I should troubleshoot this?

Plugin management log

  • Install Unknown :

A restart is needed for the changes to take effect.

Hello @Goody!

Could you please share the octoprint.log?
I assume an untervolatge issue.

octoprint.log (766.9 KB)

Ok, so no undervoltage issue, but this here:



Importing the numpy C-extensions failed. This error can happen for
many reasons, often due to issues with your setup or how NumPy was

We have compiled some common reasons and troubleshooting tips at:

Please note and check the following:

  * The Python version is: Python3.7 from "/home/pi/oprint/bin/python"
  * The NumPy version is: "1.19.2"

and make sure that they are the versions you expect.
Please carefully study the documentation linked above for further help.

Original error was: cannot open shared object file: No such file or directory

Ok. I think that’s from a plug-in I tried to install from URL that didn’t work. How do I clear that out?

After ssh-ing into my Pi, I followed the solution documented in this StackOverflow post to fix numpy:

sudo apt-get install python-dev libatlas-base-dev


Before this, when attempting to verify the version of numpy installed, by running python3 and typing import numpy it said that it wasn't installed, even though pip3 said it was. So I uninstalled then re-installed it:

pip3 uninstall numpy
pip3 install numpy==1.9.2

... then importing numpy gave the same error seen in the logs. (So this step may not have been required). After the apt-install stage, numpy imports OK, and the Bed Visualizer plugin loads properly.

It's also worth noting here, that I ran the Python2-3 upgrade script just before Christmas. I suspect it's this which has somehow broken numpy.

It's the Python 3 version of Numpy that requires this system dependency, which will be preinstalled on OctoPi 0.18.

The pip3 commands you put probably didn't change anything since OctoPrint runs in a virtual environment. So the correct path would be ~/oprint/bin/pip in this case (assuming OctoPi install)