Printer connection problem


I am running a Raspberry Pi 3 Model B+ that's connected to a Flashforge Creator Pro. I am trying to login into it and it keeps timing out while connecting. I have changed the settings from auto to the other option given for the serial port, as well as changed it from auto to the other selections for the baud rate and still nothing. I have noticed that on a couple settings for the baud rate it makes the sound like when you first turn the power on, but still doesn't connect.

This is the same for all baud rate settings.

Connecting to: /dev/ttyACM0
Using Malyan/Monoprice Connection Fix Plugin to create serial connection
Changing monitoring state from "Offline" to "Opening serial port"
Connected to: Serial<id=0x6a445cb0, open=True>(port='/dev/ttyACM0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from "Opening serial port" to "Connecting"
Send: N0 M110 N0*125
Recv: �\x01���\x01���\x01���\x01���\x01��
There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Any help in figuring this out would be appreciated,


Do you have the OctoPrint-GPX plugin installed?


I didn't have it but saw that after I posted this problem and tried it and everything seems to work great now.