Printer Statistics plugin fails to install

Tried to install the Printer Statistics plugin on OctoPrint via the plugin manager but it hangs during the installation process, see screenshot.
I am running Version 1.6.1 of OctoPrint in a Docker container on a Raspberrypi3 A+.
Printer statistics
Installed ''apt install libatlas-base-dev'' in the container as advised on: GitHub - AlexVerrico/octoprint-stats: Stats for your octoprint instance. Mirrored from originally but it didn't help.

Any advice is welcome. Thanks.

Tried manual install, but same result the installation process stops:

Do you have any news about the problem?
I have the same issue.
Octoprint 1.7.0 running in docker on a RaspberryPi 3 (raspbian buster, 5.10.63-v7+)

root@9bdecf5f37ca:/octoprint# pip install ""
Using cached
Preparing metadata ( ... done
Requirement already satisfied: OctoPrint in ./plugins/lib/python3.8/site-packages (from OctoPrint-Stats==3.1.2) (1.7.0)
Collecting tinydb
Using cached tinydb-4.5.2-py3-none-any.whl (23 kB)
Collecting pandas
Using cached pandas-1.3.3.tar.gz (4.7 MB)
Installing build dependencies ... done
Getting requirements to build wheel ... -

After some time the raspberry pi hangs up and does not respond until power-cycle.