PrintJobHistory not capturing my prints

Hi, I've been using Print Job History for a while now, but then it suddenly stopped working. I already tried to reinstall the plugin, but that doesnt help. I added the octprint logs if that helps. octoprint.log (28,9 KB)

edit by mod: log was leaking database pw - replaced it with something else

I looked into your log and found the issue:


Please go to your settings and switch to FilamentManager, because PJH V1.12.dev1 is not compatible with the old SpoolManager 1.3.4.


I am currently developing/testing SpoolManager 1.4.0, but it is not clear when I can do a release.
Unfortunately I have a lot of other things to do ("private challenges"), instead of having fun with OctoPrint and it's community.

1 Like



I have a problem with PrintJobHistory too. I'm running both the latest versions of Filament manager and the plugin. I'm not getting the edit dialogue box after the print and I keep on having to do a refresh after each print for the list to populate. Also, that Filament Dialogue box above I don't get. Please advise.

Sorry for the late response. I will try this later, thank you!

1 Like

Thank you, is working now :slight_smile:

1 Like

I just printed something and it still doesn't work. Any advice?

I've attached my log..

octoprint.log (112.4 KB)