Prints cancelling mid print?


I installed 1.3.6 last week and did several prints with no problems. After installing 1.3.7 I noticed one print that seemed to cancel mid print for no reason and everything just stopped in place. Octoprint web interface said it was paused but I couldn't get it to unpause. I reloaded octoprint and restarted from scratch. I then updated to 1.3.8 and installed the PSU plugin. I've had three different prints stop for no reason.

Last night I started a print and it got almost completely through but near the end it stopped, went home, and retracted all the filament out of the machine. There was nothing in the logs to show that it had finished, paused, or canceled. The logs showed a server heartbeat before and after the print stopped.

I rebooted octopi and tried different prints.

This is on 1.3.8, on a CR10S with Marlin TH3D U1.R1.6.


No direct experience but it sounds like communication issues. I'm guessing the folks who can help figure it out are going to be asking for the serial log at the very least. This link might be helpful in getting the serial log.


I'm not positive but this may be related to this topic. Since you say that it is happening for "no reason", I believe your best course of action would be to collect the log files and either open a ticket against OctoPrint or post the logs (including serial.log) here.


Just to confirm that yes, I'll definitely need a serial.log here. And a full octoprint.log.


I'm sorry I haven't replied. Death in the family. Ill get these logs tonight.


The logs from the other day are gone but I noticed tonight that when I tried to cancel a print I just started it wouldn't do anything. It just says cancelling and keeps right on heating up.

serial (1).log (15.1 KB)


octoprint (3).log (5.3 KB)


2018-04-23 05:23:29,878 - Send: N1 M190 S70*94

That is a "heat and wait" command, it will ignore all incoming requests from the host and continue heating up until it's done. That behaviour is totally normal.