Problem to connect to the wifi network

I have a Raspberry PI 3B + and I'm having trouble connecting to wifi.
I installed version 0.18
I configured the octopi-wpa-network.txt file as follows:

wpa / wpa2 secured

network = {
ssid = "name"
psk = "password"
country = FR # France
my network is hidden.
even if I add the line for the hidden networks I cannot connect.
I tried with several wifi networks, unable to connect.
How to do ?
thank you

Hi :slight_smile:

According to this guide you need to add a line.

Hidden networks

If you are using a hidden network, an extra option in the wpa_supplicant file , scan_ssid , may help connection.


You can verify whether it has successfully connected using ifconfig wlan0 . If the inet addr field has an address beside it, the Raspberry Pi has connected to the network. If not, check your password and ESSID are correct.

Unfortunately with these changes it does not work either is my SSID and password are correct

You could try to make it visible for a few minutes and run a scan with ifconfig wlan0
We had a case where an unexpected space was added to the SSID and the user wasn't able to connect to his wifi until he also added that space to the SSID in the config.

I opened the wifi, still the same problem

Did you maybe activate some kind of mac access control on your router?

You might try working through this WiFi Setup and Troubleshooting guide.

If the troubleshooting guide doesn't solve your problems, post the results you get from the commands in the "Other diagnostic commands" section here and we'll see if we can figure it out. Note that some of the troubleshooting commands may not work unless your WiFi is visible. So if you can change your WiFi to be visible, at least during troubleshooting that will help.

I performed the scan and it detects me well the network but can not connect it looks like
Here is the result:

Cell 09 - Address: B2:D7:29:44:00
Frequency:2.472 GHz (Channel 13)
Quality=70/70 Signal level=-40 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 9 Mb/s
18 Mb/s; 36 Mb/s; 54 Mb/s
Bit Rates:6 Mb/s; 12 Mb/s; 24 Mb/s; 48 Mb/s
Extra: Last beacon: 90ms ago
IE: Unknown: 000A46524545454D41582D33
IE: Unknown: 010882848B961224486C
IE: Unknown: 03010D
IE: Unknown: 32040C183060
IE: Unknown: 0706444520010D14
IE: Unknown: 33082001020304050607
IE: Unknown: 33082105060708090A0B
IE: Unknown: 050400010000
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : TKIP CCMP
Authentication Suites (1) : PSK
IE: Unknown: 2A0104
IE: Unknown: 2D1AAC0117FFFF000000000000000000000000000000000 000000000
IE: Unknown: 3D160D00000000000000000000000000000000000000000 0
IE: Unknown: 7F09010000000000000000
IE: Unknown: DD180050F2020101000003A4000027A4000042435E00623

How did you edit the file? If you used notepad/wordpad, it adds a hidden linefeed to each line and Linux chokes on those.

The good news is that the Pi sees your network and it has a strong clear signal. So we know this is an issue with the log on process.

Did you work through all of the suggestions in that guide? If so, what program/app did you use to edit the file containing your WiFi information? Using the wrong one can screw up the file.

Another other thing you might try:
I noticed that your first post that you appear to have deleted the spaces in front of the ssid and psk lines. It's important that these lines be indented (and also the line scan_ssid=1 line if you have added that for a hidden network). They should all be indented the same amount. Do not indent the network={ or the } lines. If the indenting is messed up, it will not work.

I did it directly from Nano on Octopi

Indeed it is the formatting of the forum which did not indent me the spaces

Preformatted textssid="FREE"
Preformatted text psk="motdepasse"

the network is a visible network (originally hidden that I made visible for testing)

Again, it appears you have not indented the ssid and network lines (unless in your cut & paste, the leading spaces were deleted by the forum software? To avoid that happening when displaying code, use the code format button, which looks like this: </> and paste your text in the indicated space which pops up).

For a network with a visible ssid, it should look like this:


For a hidden network, it should look like this:


Having the indent in front of those lines makes a difference.

Also, is your network a visible network or hidden?

Indeed it is the formatting of the forum, I have a correct indentation as you show it

the network was originally hidden, I made it visible for testing
But despite all this, it still doesn't work

I continue my tests because it is still not resolved, I manage to connect to the terminal of my "Freebox" operator in France, but I have another Wifi router that I use as a replacement as a replacement terminal of the Freebox for which I deactivate the Wifi, because it less efficient.
The kiosk I use is a Cudy WR-1000 kiosk. In my opinion there are probably settings to be made on it, but I have tried everything. If anyone can help me.
Thank you