πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Problem with PrintTimeGenius

I've been using PrintTimeGenius for a few months now and it works great. However, in the last week, I've started having an issue. I slice my model in Cura and click Print with OctoPrint. It sends the file to Octoprint and then Cura displays "Waiting for G-Code analysis to complete...." I see the file uploaded to Octoprint but the g-code analysis never completes and doesn't start printing. It just sits there until I either cancel the whole job or click the Print Now button.

I've tried large files (50+MB) and small files (less than 1 MB). Never finishes the analysis and starts printing. I've reset the analyzers within PrintTimeGenius, nothing. As a last resort, I've completely uninstalled the plugin and cleaned up all the data, then reinstalled it. Still nothing.

Suggestions?

How do you know this is a problem with PrintTimeGenius? Maybe it is a problem with the Cura OctoPrint plugin. @fieldOfView may be able to advise exactly what signal the plugin is waiting for here.

Does it work fine uploading directly in the OctoPrint UI? Does it work with PTG disabled?

Can you also upload the systeminfo bundle so we can have a look at the logs and see if there are any errors?

You're right. I"m not 100% sure it's PrintTimeGenius. I figured it was because when I disable the plugin and restart Cura, print upload and start just fine from Cura with the OctoPrint plugin.

I can upload files directly to OctoPrint when saved through Cura with or without PTG disabled. However, I don't get the little star next to the file name indicating PTG has done its analysis. I also go into the OTG settings and try to manually run the analysis. I've never done that before but I'm not sure if that is working either because again, I don't get a little star next to the filename.

I have uploaded the systeminfo. Also uploaded the PTG logging.
octoprint-systeminfo-20220615124213.zip (170.6 KB)
plugin_PrintTimeGenius_engine.log (955 Bytes)

It seems that you have multiple plugins that are all trying to analyse the uploaded file, so it could be taking a while and have conflicts in the process causing problems.

  • OctoPrint's built in file analysis
  • OctoPrint Dashboard
  • PrintTimeGenius
  • Slicer Estimator

I wonder if the last two may be conflicting, since they are both trying to do the same thing. They could be getting in each other's way and resulting in the analysis taking much longer to complete. I would say you only need one of them.

I uninstalled the slicer estimator, PTG, and Dashboard just to give it all a fighting chance. Re-installed PTG and it seems to be working great now. May try to install Dashboard again but if it breaks it then I know. For now, I'm assuming it's just the Slicer Estimator so I'll leave that out because, like you said, they do similar things and may be conflicting.

Appreciate the help!