Problem with setting up the Pi


I forgot my admin password so I decided to completely wipe my sd card and just reinstall. I wiped the card, noticed there was still 100 kb left on it which I coudn't remove but installed octopi as usual. When I tried to acces it via ssh nothing happend. I use mac and so terminal. I typed the usual stuff: ssh pi@octopi.local but nothing happened.
What went wrong? and how do I fix it?


Can you ping the pi on octopi.local?


What does "nothing happened" mean? It times out? Did you set up your network with the new octopi install?


No, it says that this page is unavailable


Nothing happens, the cursor goes down and the name of the terminal window changes but thats it.


on the SD card, that is.


yes, and I double checked if i forgot to remove the #'s


If you can't even ping it (ping octopi.local) it might not have booted properly or the WiFi config might be broken. Take a look at

Especially the bit about editing the config files on a Mac.


I don't really have that much experience with programming but I assume you put that command in terminal so I did. It gave me a can not resolve octopi.local: Unknown Host
But I'll look into that article.
just a quick question, does pluging it in with an ethernet cable solve anything?


If running it like that is an option for you then most likely yes.


Plugging it in via an ethernet cable means you don't need to do any of the WiFi stuff (edting your SSID and password in either octopi-network.txt or octopi-wpa-supplicant.txt, whichever on of those you are using for WiFi).


I tried everything that was in that guide but it still doens't work.


Do you know that your Pi is even booting up? Can you connect with an Ethernet cable or temporarily connect a monitor and usb keyboard to the PI? IF neither of those are a possibility, can you at least describe what the red and green lights on the Pi do when you first power it up?


I've also been having issues. Just blinks 4 times slow and for times fast. I just saw a post somewhere hinted that jessie doesn't work on the new pi 3B+. Is that true? I might have roll my own on stretch until they release a new version of octopi based on stretch. ugh. or deal with my old slow pi 2B.


@go_cbj, here's the howto on the 3B+:


@Jamrulezz Have you changed the configs in /boot/ on the SD card? If so, show those, just elide your password(s). If you plug it in via ethernet it's much more likely to work, because it doesn't require configuring wifi settings properly.

For "how do I find my pi", you need to get the IP address to the pi. You have a few choices:

  • use nslookup octopi.local or host octopi.local, if supported by your OS
  • connect a keyboard and monitor, see the login message, cat /etc/motd, or use 'ifconfig'.
  • use pifinder if you are on MacOS/OSX.
  • find it by looking on your router, which likely will show the DHCP clients on the network.
  • use nmap or arp, which will show you any devices with the Pi chipset on your network (but is advanced)

The first three should be possible as a noob. It's worth hooking up to a monitor even if you have to get a HDMI adapter and a cheap keyboard. The last two are more advanced.

If you can't do those and can't find a tutorial like this or this that makes sense, it's going to be hard to help you remotely.


Thanks @tedder42. Not exacltly a guide but rather conformation that it shouldn't work unless i add manually to a stretch install. Or wait...