Problems sending text/email with octotext

What is the problem?

I am trying to set up octotext but am having problems with authenticating with the smtp servers - I have tried two

What did you already try to solve it?

I tried using smtp.google.com with an app password, but it did not work
I tried creating an outlook account and using the default smtp server, but it did not work
This is what I get in the log:
Jun 11 20:04:00 octopi octoprint[416]: 2021-06-11 20:04:00,716 - octoprint.plugins.OctoText - ERROR - Exception while talking to your mail server [Errno 101] Network is unreachable Jun 11 20:04:00 octopi octoprint[416]: File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_OctoText/init.py", line 231, in smtp_login_server

I am able to successfully ping both smtp servers from the pi

Have you tried running in safe mode?

No

Did running in safe mode solve the problem?

Have not tried

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Safari/537.36
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1400
env.hardware.ram: 915058688
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Plus Rev 1.3
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x80000
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.6.1
printer.firmware: Marlin Creality 3D
systeminfo.generator: systemapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I have auto bed-leveling, octolight, and a web camera working.

tagging @stephenwberry

1 Like

Sorry you are having trouble. The error would seem to indicate that the smtp address was incorrect. Can you send me a full log? - but first please make sure that you are logging OctoText in DEBUG mode.

I guess you just need to try it 99 +1 times. I was finally able to get it to work with smtp-mail.outlook.com, port 587, no SSL.

Even the snapshot is working! Very nice plugin, if not finicky to get working initially

1 Like

I'm going to guess that you are not in the US - the outlook email SMTP address changes for other countries.

As for your webcam, it just needs to be enabled and working. You can check in the settings page under webcam and timelapse - if the test button works, you should be good. If not, I'll need the log file.

You don't need octolapse.

oh, you got the snapshot working! good, never mind that part then lol. Glad it is working for you.

I am facing the same problem. Please give some solution related my issue.

www.mybpcreditcard.com

For some reason the outlook smtp server stopped working. I tried the Gmail server with an application password and now it has decided to work. Very weird