PSU Control Options


#1

Greetings all-

I followed this guide to set up my ATX PSU with RAMPS/Mega and Octoprint.

It took a little bit to work out the Custom Controls buttons, (Chome & Right click) but I have two buttons assigned to M80 and M81 to turn off and turn on the PSU. I can turn it on and off remotely.

Now I am trying to set up the controls in the PSU plugin and I am confronted by too many options.

The RAMPS board has the PS_ON signal assigned to the D12 pin. The D12 pin is connected to the green PS_ON wire on the ATX PSU. Its exactly like the schematic and these pictures- red wire is +5V and the green to black is the PS_ON wires.

"https://github.com/AndrewBCN/RepRapImages/raw/master/RAMPS1.4-fuse_layout.png"

"https://github.com/AndrewBCN/RepRapImages/raw/master/ramps_to_atx2.png"

I can not seem to get the correct settings assigned to the Control or Sense options.

by reading the wiki page for the plugin, I though I would set the Switching method to 'System Command' and Sensing to GPIO pin and 14, but I can not figure out if its a floating, pull up or or pull down .

Is there a better way to configure this?

Thanks in advance

sinneD


#2

As bad form as it is to reply to your own post, I figured out the issue- for some reason, the pulldown menus for GPIO did not clean nicely when I selected System Command or Internal. I was getting the same options for both even though I changed the method.

Once you select the Internal option for sensing, the plugin will determine the last state of operation and report based on that.

Here is the configuration that works for me now-


#3

Hi. I´ve added a relay board to my raspberry pi, and am using it to control power supply. I´d find out that this plugin can be used to run the scripts I have to send GPIO commands, and turn on and off the power supply, making my room quieter when it´s not printing yet.

I´ve run in a problem with "Automaticaly turn PSU off when idle". If I select this, the PSU doesn´t turn off when printing, but it does when I´m running a bed leveling G29 P1, for example.

I wish I could set this to 1 minute, for example, so it shutdowns the noisy power supply as soon as the printer ends. Is there a way to do this?

Tks.


#4

Johnnie-

That is how I have mine set up. I have it set to power off after 3 minutes...

  1. Do you have Heater Timeout?
  2. Does you end print script had a cool down cycle?

You printer might be 'waiting' for something else to happen before powerdown. Check for conflicting things like that. Check the terminal for messages.

1 minute might be too short all all around. Try for 3 or 5 to see if that works.

Edited to unblock 'spam' rating?
Edited again..


#5

I have no heater timeout and no problem when printing. The problem is when I power up the printer, and issue a G28 and a G29 P1 to level bed cold, for example. I understand that it should not turn off the power supply if the printer is not idle, and for me when it´s running a bed leveling routine it is not idle.

I´ve increased it to 10 minutes, but I wanted to keep it as short as I can.