PSU Plug-in not saving settings?

I wonder if anyone knows how to rectify a niggling ‘fault’ which I am suffering from in the PSU Plugin?
When setting the switching mode to ‘GPIO’ and saving the settings. The plugin functions correctly and turns the printer off automatically as set. But on a random occasion the printer stays on and when looking in the PSU settings the switching mode has changed to G-Code Command?
Is there anyway of sorting this out?

If it were me, I would visit the Settings page for that plugin... then open the browser's Developer Console and make sure that the page isn't throwing one or more ugly JavaScript commands which might prevent you from actually saving any changes to that form.

Secondly, having "saved" the GPIO option in that area of the Settings in OctoPrint, I'd immediately cat ~/.octoprint/config.yaml and verify that the plugin actually saved that attribute, as expected.

Once satisfied, I would wait for this to misbehave again and then cat the config file to see if something has toggled it back.

Many thanks to you.
much appreciated I will try your suggestions and report back.

Thanks again

I noticed that the printer hadn't turned itself off yet again, and it wouldn't turn off manually either.

I ran the 'cat ~/.octoprint/config.yaml' and it showed correctly that the GPIO was selected as the switching, but when looking in the settings of the plugin, i find it has reverted back to the G-Code Command setting. I ran the browser Developer Console and noticed that on pressing the save button the console reported' configured loggers has not changed. not saving.

I don't know if this is normal?

What you've included above is a reference to something in your own installation so it doesn't help us too much. In HTML terms "packed_core.js" would be the result of packing a bunch of bundled plugins' combined JavaScript and so who knows what that bit of code was trying to say.

You'd be looking for, say, a red circle/triangle with a number in it which is trying to indicate one or several JavaScript-related errors. You'd then visit the "console" tab within the Developer's Console to see which particular error(s) it might be trying to communicate.

The usual culprit (when a 3rd-party plugin has problems) includes something like "can't display/bind (to) viewmodel" or something like that. In JavaScript terms this means "go ahead and press the SAVE button but nothing's really going to happen".