PSU plugin fault/advice getting the sensing to work correctly

I'm hoping someone can help - it's driving me mad!
I've set up the PSU plugin in the way I would like and through trial and error have eliminated as many potential problems as I can think of. I'm in a position where it will only work then the green power symbol displays the wrong way around. Whenever I "invert" this display, the green toggle button simply does not toggle the relay.
Octoprint v 1.4.2
Relay connected to GPIO25 (pull-down)
Switching set to GPIO 25 not 'invert'
Sensing set to GPIO 25 float 'invert'
Power supply is good, no other connections on GPIO pins. Relay power being taken from 4 and 6

Octoprint boots up, switches the relay on and shows a green toggle symbol but this button now does not turn the relay off again.
I've tried using pull-up, different GPIOs, setting the sense to pull up and down and whenever the toggle switch shows in the correct sense according to the relay, this switch does not seem to be clickable.

I'm at the point of thinking there might be a problem rather than me having the settings incorrect.

Does anyone have any ideas? Will any logs help? Details of other plug-ins? I'm stuck!

I've continued to work on this but with no more success. I will update my findings in case it helps anyone else.

I've tested many pins with many combinations of settings to come up with this

Board number Pin type Switching Sensing Sensing Activates on boot? Correct sense?
26 pull-up invert internal invert yes no
26 pull-up - internal - no yes
26 pull-up invert GRIO invert yes no
26 pull-up - GPIO - no yes
37 pull-down invert internal invert yes no
37 pull-down - internal - no yes
37 pull-down invert GPIO invert yes no
37 pull-down - GPIO - no yes
16 pull-down - GPIO - no yes
3 pull-up - GPIO - no yes

so I basically need either a YES and YES or NO and NO but when I invert the sensing reading the green power button stops working and the auto-off also stops working. I have the same problem whenever the 2 invert options oppose each other. It feels like I am so close but something is fundamentally wrong.

I wonder if using "System command" for sensing will be better? Does anyone have any idea what the code might need to be for this? I have no experience of this.