Raspberry Camera V1.3 no works with the new Stack

I'm starting to wonder if the Pi 3B (with latest camera stack / kernel) has some issue with the old 5MP camera/sensor. As with many issues, online searching shows all kinds hints or similar problems - many of which maybe totally unrelated or wrong.

I'll see what I can experiment with when I get a chance - I have an Arducam 16MP AF camera lying around and also a Pi Zero W and Pi Zero 2 I may be able to swap around to see if any combinations work. Maybe I can pick up a cam v3 to try too (eventually using the Arducam or a new v3 was sort of my aim in trying this new camera stack anyway).

A few links I've found interesting when looking into this:

I've noted increasing the timeout value (seen in top link above) seems to make the timeout error go away but the camera still fails to function.

i tried running crowsnest and mainsail and couldn't get the camera to work on bookworm so installed everything on buster and then it worked when i changed the dtoverlay manually so can it be that something is missing in the newer versions?

I was able to run a few basic experiments with sort of interesting results.

Arducam AF 16MP
Starting with my same Pi3 device and SD card image I merely swapped the camera to my Arducam 16MP.

On boot this camera was not listed with libcamera-hello --list-cameras so I edited /boot/config.txt to add dtoverlay=imx519. On reboot the camera was listed and the webcam feed was working - neat.

Pi Zero 2W w/ Original v1.3 Camera
I then swapped the SD card into a Pi Zero 2W and connected my original v1.3 Camera to the device. In this case I needed a new ribbon cable as the Zero has a different interface, but I don't suspect the ribbon to be an issue as it worked before swapping my SD card for the new stack image AND it worked fine in the previous Arducam test.

Here, on boot, the camera was also not detected, but I suspected it due to my recent changes for the Arducam 16MP test above. I went back and removed the dtoverlay=imx519 from /boot/config.txt and rebooted. Upon restart the camera was detected again, and to my surprise, it showed up for the webcam view - weird.

Original Pi3 w/ v1.3 Camera and Shorter Cable
Just out of curiousity I wondered if somehow a shorter ribbon cable would help - maybe something weird with the later kernel/driver for Pi3 running a bad clock frequency to the module that is causing issues.

I moved the SD card back to my Pi3 and moved the v1.3 Camera to it as well, this time with a standard 5" or so ribbon cable (I've been using nearly 3ft for my printer). Upon boot I see the camera with libcamera-hello --list-cameras and it seems to show in the webcam (my first post of this said it did not, but I think I had a stale HTTP connection).

So it seems like something in the new stack or kernel/driver has affected my ability to use the v1.3 Camera with a longer ribbon cable?

Have you tested with the longer cable again after the swap back?

I have a pi 4 i need to test if the camera working on it with the new stack if it is just the 3 b+ that is the villain

I don't think it's the cable length. I tried short and long and three Picams v1.3 from different suppliers. All without success.

As much as I wonder what's happening with this...

My data in order

  • Original camera stack with Pi3 and v1.3 camera using 1M cable was working for ~2 years
  • Same device w/ new stack failed - fails with strange frontend timeout error, although camera found (1M cable)
  • Swap to ArduCam with that device (and 1M cable) - works
  • Attempt v1.3 camera w/ same SD card image (As above) and Pi Zero 2W - required using new Pi5 camera 300mm cable - works.
  • Swap to Shorter cable with v1.3 cam and Pi3 - works
  • Back to Longer cable v1.3 cam and Pi3 - failed
  • Back to Longer cable w/ ArduCam - works

I'm still also skeptical that it's the lone issue, maybe some strange sensitivity or lack of margin that with my particular device and camera the cable length makes a difference?

I'm now in the process of designing and printing a new enclosure for my Arducam and aim to just use that with my setup since it seems to work with the new camera stack, my Pi3 and my longer cable.

This is strange. I put the same sd card in my Pi 4 B and it works there but I have the same strange error
octoprint-systeminfo-20240215210011.zip (20.8 KB)

I have the same issue running a 3B+.
When I updated the new image, using the latest Python install - my USB cameras no longer worked. (All of them worked flawlessly on the previous install of Python).

The cameras I use were cheap USB (Sony PlayStation Cameras) - but they worked up until the new Python install.

I gave up on trying to resolve the issue. (I am not a programmer, nor do I have the time to devote to learn code)

I am a monthly subscriber to OctoPrint to help support the continued development. (Hopefully this can be resolved with an updated release - Hint-Hint)


This particular thread is about a Pi Cam V1.3 - these aren't USB cameras. It might be better to open your own thread. If you're seeing the same "stale stream" server errors, then maybe it's similar but these cameras use different drivers so it's unlikely to be exactly the same.

Everyone seems to be having a problem with these camera now which wasn't happening before. I have tried reimaging new stack , old stack, different cables, different cameras - all the same now. What was working easily before is now very convoluted - why ? I have tried turing on i2c, off i2c, enabling legacy camera , disabling legacy camera, etc. Nothing seems to work. 1.93 was working but not now.I even upgraded to 1.1.0 RC 2 - no better there.

I had the same problem and the issue was that the cable had gone bad. Replaced cable and all was good.

Those are OctoPrint versions. Whether your camera works or not has nothing at all to do with OctoPrint, that's entirely up to the underlying OS and camera stack installed on it.

What I can tell you is, I haven't touched anything on the OS side apart from providing an OctoPi image now with a different camera stack. I haven't touched overlays, drivers, anything like that at all. If stuff is now broken that used to work, and it is definitely not the hardware that is to blame, all I can think of is that some recent firmware and/or kernel update from Raspberry Pi is to blame.

I have a Rasbperry Pi 3 v1.2 and a new v1.3 5 MP camera. The camera is detected by libcamera-hello but I'm unable to get any pictures. I just reflashed my sd card with a new image and still same error. I do not have a monitor connected to my raspberry, some threads suggest it might have something to do with the issue.

Preview window unavailable
[0:04:46.181258791] [1030]  INFO Camera camera_manager.cpp:297 libcamera v0.0.5+83-bde9b04f
[0:04:46.247260196] [1031]  INFO RPI vc4.cpp:437 Registered camera /base/soc/i2c0mux/i2c@1/ov5647@36 to Unicam device /dev/media2 and ISP device /dev/media0
[0:04:46.247371029] [1031]  INFO RPI pipeline_base.cpp:1101 Using configuration file '/usr/share/libcamera/pipeline/rpi/vc4/rpi_apps.yaml'
[0:04:46.247916858] [1030]  INFO Camera camera.cpp:840 Pipeline handler in use by another process
ERROR: *** failed to acquire camera /base/soc/i2c0mux/i2c@1/ov5647@36 ***

libcamera-hello --list-cameras
Available cameras
0 : ov5647 [2592x1944] (/base/soc/i2c0mux/i2c@1/ov5647@36)

Just confirming that the old stack works, I did NOT do the updates octoprint web ui is offering, as PI support plugin has something to do with camera settings.

This is not true, it does not have anything to do with the webcam.

Pi Cam V1.3 seems to have wider issues with the new camera stack in general, but I have not seen any concrete resolutions yet.