Raspberry Pi 2B Wifi Issues with Buster and Octopi

Continuing the discussion from WiFi setup and troubleshooting:

Hardware: Raspberry Pi 2B, TP-Link Wifi Dongle

Raspi-config was "unable to communicate with WPA_supplicant" on setup for both vanilla Rasbian Buster and Octopi (both most recent as of 2020/03/08). I encountered this same issue on Rasbian Stretch in the past as well, and the solution was the same.


Edit WPA_Supplicant and network/interfaces like so.

sudo nano etc/wpa_supplicant/wpa_supplicant.conf


ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


sudo nano /etc/network/interfaces

auto lo
iface lo inet loopback

iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

And then: sudo systemctl enable wpa_supplicant.service

Thats it, reboot and rip it

More about this issue:
I knew something was amiss when I ran sudo iwlist wlan0 scan and was able to see all of the networks. The issues with WPA_Supplicant and interfaces files were cryptic and I had to stitch together lots of hints from different forums to solve this.


BigFin you made my day.
thank you very much. your solution did the job

1 Like

I too would like to say THANK YOU!! This was perfect and solved my issue as well!


Still VERY useful information as of today.
Thank you very much for this!


BTW: For the forum software this is not solved until:

1 Like

Oh man, almost 2 years later and your tuto saved me.
Thanks a lot.

Glad to have helped.

Updated a bit to make clear that this is a guide.