Raspberry Pi 4 is out

Hey all
So, what's this about?
Is v17 stable?
I apologize in advance if I am misinterpreting this, I am not fluent in linux.

pi@octopi:~ $ sudo apt-get update
Get:1 http://raspbian.raspberrypi.org/raspbian buster InRelease [15.0 kB]
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists... Done
E: Repository 'http://raspbian.raspberrypi.org/raspbian buster InRelease' 
changed its 'Suite' value from 'testing' to 'stable' N: This must be accepted 
explicitly before updates for this repository can be applied. See apt-secure(8) 
manpage for details.


When I try to print a gcode file,few seconds then disconnected,and shows up this message, please help, using Raspberry pi 4.And other question , When I plug in the pi camera ,or connect a fan ,then can not boot,the green led didn't flash .

Debian is the version of Linux which Raspbian is based upon. The current status of both Debian Buster and Raspbian Buster is that they're both still not-quite-finished... or are they?

Debian Buster wiki

Buster is the development codename for Debian 10.

It is the current stable distribution.

Okay, so it's supposed to be a stable version as of this month at least.

Raspbian Buster wiki

I'm guessing that guy/foosel might have done their image back when Raspbian Buster was still not yet stable, hence the notification you got.

Piere,

Please create another thread in the Get Help section so that your questions can be answered. We're here now in the General section.

Just installed the 0.17 version on my Raspberry Pi 4. Booted, immediately connected to my WiFi, configured flawlessly. Web camera is working, and printing the first model.

1 Like

Hi seems to work fine. What is expected GA release date?

Thanks for the info. I believe I was trying to install a prerequisite for a plugin and the instructions said to run "sudo apt-get update", but I was unable to. perhaps I will try a newer build.

run 'sudo apt update' and it will prompt you with a y/n. choose y and that will go away

Just got my pi4 4gb installed this build and restored my previous setup with ZERO problems. All connections transferred over and work great with the USB 3 ports. Camera setup transferred without any adjustments. If there is any additional information I can give about this build I would be happy to help!
Thank you so much!

Hello,
thanks for the image for the pi 4.
test pass:

  • octoprint OK
  • connection to printer OK
  • control printer (home) OK
  • webcam logitech C270 OK
  • GPIO BCM OK
  • GPIO BOARD FAILED

for fix:

  1. update wiringpi
cd /tmp
wget https://project-downloads.drogon.net/wiringpi-latest.deb
sudo dpkg -i wiringpi-latest.deb
  1. update python gpio lib
~/oprint/bin/pip install --upgrade --pre rpi.gpio
  1. update system
sudo apt update && sudo apt full-upgrade

On that note, I don't know if everyone's heard but Gordon, the author of wiringpi got fed up with cheeky users and decided to pull the plug on this project.

I did not know, it's ugly.
unfortunately it does not shock me :frowning:

I've been trying to connect my Pi 4 running this version of Octopi to an SKR Mini v1.1, but for the life of me, can't get the Pi to see when I connect to the board via usb. I've tried (ls/dev, lsusb, dmesg) and it appears as though it doesn't see the connection at all. The board connects fine to a PC and communicates fine via Repetier Host, just not the Pi. Any thoughts?

If you have a Raspberry Pi 3B then you might put the same microSD into that and see if that one is happy. It might not be so much a Pi4 thing as a basic setup thing.

I have a Pi 0, think it would be able to handle the imaged Octoprint?

Nope.

It's good for a dedicated webcam server, though. (Search the forum for that.)

I plugged in a standard empty USB stick and the RPI4 recognized it right away, so I have narrowed the problem down to the Pi recognizing my SKR Mini board, but am clueless on what to look at to resolve the issue. All I know is that after running "sudo dmesg -C", then plugging in the USB cable to the Pi, then running "dmesg", the Pi reports back nothing.

Not sure what to tell you other than to verify that your serial cable is good.

Serial cable is fine, as it connects my old Anet board to my Pi 0 fine and the SKR mini to my PC fine.... which is why this is so frustrating. But I appreciate the attempt to help.

Okay, work with what you know: what device did Repetier Host use for it?