Raspberry Pi 5, CR-30, plugins install

What is the problem?

After a few false starts, I finally got OctoPrint installed using the octoprint_deploy script. Now I am trying to add all my plugins, but I can't seem to get FilamentManager installed. It says it was installed correctly, but it isn't in the list, and when I restart, Print Job History is still complaining that it is missing.

What did you already try to solve it?

Tried URL install, select from Plugin Manager

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20240428102800.zip (123.2 KB)
You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Additional information about your setup

OctoPrint version 1.10.0, OctoPi version N/A, printer, firmware, browser Edge v124.0.2478.51, operating system Windows 10 22H2 build 19045.4291, ... as much data as possible The shared database is on my NAS, and works for all my other printers. The client has already been added to the Pi5 setup.

It looks like Filament Manager is struggling to work with the most recent Python versions. It's throwing an error while loading, for collections.MutableMapping. This was removed in Python 3.10, so I guess the plugin does not work with Python 3.10 or newer anymore.

That's why it won't load. I'm writing this on my phone so not able to dig through to see if there's existing issues already reported surrounding this - I suspect there will be. I know that this plugin is not really maintained anymore.

Since an update on the plug-in side doesn’t seem imminent, is it possible to roll python back to 3.9? Or would I be better off using SpoolManager? I’m trying to find a solution I can connect all my printers to. It’s too bad that OctoPi doesn’t work with RPi5.

I'd say switch to either SpoolManager or perhaps Spoolman with OctoPrint-Spoolman.

I believe there are daily builds of OctoPi for RPi 5 or you can use OctoPrint_deploy.

Thanks, guys! I decided to use Spool Manager, even though it doesn’t support a shared database. Oh well. I’ll have to manage keeping things in sync between the CR-30 (SM) and the Enders (FM) manually.