Raspberry pi touchscreen (Full Screen)

Remember that kiosk mode thing I spoke about earlier. That's the fullscreen thing you're looking for.

1 Like

Yeah I’m trying, I must be doing something wrong....uuuugggg

Does this look correct? I’m doing this through Putty just so you know, maybe that’s the issue?

First things first, append this at the end of the file and not the beginning. It needs to be on a line by itself.

Second things second, a pound sign in a bash script marks a comment. So you definitely need to remove that if you want this to run when you log in automatically after the reboot.

If you want to, you can test this from the Pi itself:

  1. You're in the Desktop GUI environment because it's automatically booted up into that
  2. From the menu, you find the Kermit terminal and run that
  3. From that Kermit terminal, enter that line:
chromium-browser --kiosk localhost

What should happen is that a new Chromium window should show itself in fullscreen mode. By moving your cursor to the upper/left, you should have options like to not be in fullscreen mode or to exit, perhaps. Assuming that this works then you know that you've successfully installed Chromium on your Raspi.

Having edited the .bashrc correctly and rebooted, it should then automatically bring up the browser in fullscreen mode to your install of OctoPrint.

1 Like

Thanks man, that’s an easy fix, I will try that tomorrow and let you know my results.

I must still be missing something because Octoprint still won’t boot up into full screen mode?

Does this look correct?

Looks right to me. And you rebooted, right?

Try that command by itself as I described earlier in this post: "If you want to..."

yup I entered in
chromium-browser --kiosk localhost
And it opened up another Octoprint but it was exactly the same as the original...didn’t go to full screen. I’m pretty sure I rebooted, I turned the Raspberry pi off and then back on again so it could reboot.

Alright, from the command line try this version: chromium-browser --start-maximized localhost

Ok I just tried this with the same results, I must be missing some little thing somewhere?

When I open up my putty I see this WARNING, do you think it has something to do with it?

Alright, then...

DISPLAY=:0 chromium-browser --start-maximized localhost

Nothing...same result. :cry:

Oh well, we tried. Just manually bring it up, I guess.

You might want one of these which I have on my own printer install.

What do you mean by manually bringing it up? My Octoprint is coming up on its own just fine just not in full screen

I guess I mean, bring it up (press F11) manually rather than programmatically.

I guess I just don’t have any luck, F11 don’t work either from my Bluetooth keyboard that I have hooked up to my Raspberry, maybe I will get the keyboard that you just posted, that looks awesome!

Well, there's a maximize and fullscreen mode option (I'm pretty sure) from the Chromium menu as well.

Funny you say that I looked for that setting the other day but couldn’t find it, do you know where it is?

Pretty sure it requires a mouse and you move it to the top of the screen. You also might try Ctl-Alt-F for fullscreen.