RaspberryPi imager versus Balena

Just curious as to if anyone else had an issue installing Octopi on a Raspberry Pi using the recommended imager? Spent several hours installing and reinstalling only to have the browser not being able to connect, even though I could connect via PuTTY and see it on my network. Finally gave up and went back to my old stand by way of installing using Balena and was up and running in less than an hour.

I just tried (using the Raspberry Pi Imager) and imaged the latest onto a 32GB micro sd card. It worked correctly and I was able to login and start using it.

Hmmm, interesting. Not sure if it is the sdcard or what??? I ran the imager on three different 16 gb micro sd high speed class 4 and could not make a connection with either browser (Opera or Edge) although I could connect using Putty. I used two differnt downloads of the imager also. Anyway, I have it running fine using the Balena etcher, so not a big issue.

In the Raspberry Pi imager, did you definitely select the correct OctoPi image? That has caught some people out, whereas with Etcher you have to download it first.

That is the problem. Another look at the steps revealed I just installed the RP OS.

For imager, download which octopi image you want, then in imager, select "other image" and select the one you downloaded.

OctoPi is available in the Raspberry Pi Imager without downloading. Go to 'Other Specific Purpose OS', then 3D printing, then select OctoPi.

Thanks Charlie. I did find it after some searching. Next time I'll pay a little more attention to the instructions.

I did find them in the menu once I realized that the imager wasn't just for Octopi, but for other systems too. Kind of a slap your head moment.

etcher can also flash images via url - but yeah you have to search for the url first.

BTW, I created a fork of the Rpi Imager that includes unofficial images:

Initially because the official one had issues with OctoPi.

did you change the defaults to be your Internet on the SD card before plugging it into the Pi and turning on;

The Pi can take a long 30 seconds plus or to to fully boot and connect; It may look like it's not going to work at first.

File on SD Card need setting to you Internet:-


These have to be correct

I use Balena Etcher; and it you also used it and it works you know this :face_with_diagonal_mouth: