Raspbian browser

So I have spent at least 10 hours to upgrade to python3. So much Trial and error. Took a full copy of my raspbian partition that I rebooted to and tested everything there before I finally got everything working... I thought.

Previously, I had python2 and Octoprint 1.6.1 and the local installed Chromium Browser (v74) worked just fine. But now with python3, Octoprint 1.7.3 hardly nothing work correctly in the browser. I have kept my old Octoprint folders with 1.6.1, and If I switch back everything works. If I connect with my windows 10 computer the 1.7.3 also wórks fine. There seems to be no update to the current version of Chromium...


  1. What have changed in 1.7.3 so that I cannot use the Chromium v74 anymore?
  2. Can someone guide me to alternative browser for raspbian that do the work?

As a windows ordinarie user, one might think that this kind of problem shouldn't exist but
I don't have much experience of Linux, so....

You can check the changes either on github

or in the Octoprint blog

Another thing you could try is to backup your Octoprint via the backup and restore menu, flash the latest image to your sdcard and restore it again.

Well, this week I have learned that the backup system is not that trustworthy. I'm sure it works fine with all settings, but when it comes to 3:rd part plugin... When I hade done my upgrade and had everything working in my test partition, I took a backup of Octoprint and did a "clean" install in my main partition and when I then tried restoring the backup, it all went wrong... I kept the 1.6.1 octoprints folders (just renamed them) so I just have to repeat the whole damn thing again with manually install most of the plugins again (The settings for them was kept though). Anyway, It seems like firefox works. A quite unnecessary "heavy" browser for the mission, but at least it works... Thanks for your suggestion anyway. I might do a fresh installation with a later version of rpd-x86.iso. I expect we soon must move to python 4 or something, and backward compability doesn't seem to be the strongest part of this world...

I really hope we don't have to - though I think the Python foundation admitted that the move from 2 to 3 was too painfull.

1 Like

Found the issue why I wasn't able to restore the backups in Octoprint... I had set the Locale settings to Swedish. Setting it to English seems to solve it... Feel like going 25 years backwards...

1 Like