Restriction on password characters?


I have registered as a user a few minutes ago. My first attempt hadn't worked, there was a message (sadly I haven't saved it) that it could not be determined if the account was created and I should ensure that cookies are enabled. Cookies are always enabled.

I attempted a second time, and it worked flawlessly. The only difference was the password.

The working password is 40 characters long with upper and lower case and numbers.

The first password was shorter but contained special characters. As I don't use it and my passwords are random generated I can show it here (I hope it won't be mangled): ~-L-<p9L9VXV}~]HSB_"

Maybe there is a bug handling one or more of these special characters.


you registered here, or created a user on your octoprint box?

The problem was with registering as an user on

Apart from the password and the description of the printer I use all other input fields were remembered by my browser as I made my second attempt to register. The description of my printer (Anycubic i3 Mega s) isn't very special :wink: and I think I have typed it both times the same.

As I encounter problems with my passwords very often my first attempt to rectify was to use a longer one with reduced character set. I wasn't much surprised as the second attempt worked. I was surprised about the either missing explanation about the allowed characters or bug.

it appears the restriction is minimum 10 chars, maximum 255, no real limitation on special chars. I know what you mean about having "too good" of a password, I've had that too. I don't know what caused it, though.

Thanks for the pointer to the password-validation.

But I don't think the problem was this validation in itself but something other got confused, otherwise what sense makes the message about making sure cookies are enabled.

Anyway, I only wanted to mention this problem in case there are others encountering the same (I havn't found anything about this searching the forum) and this isn't an isolated incident.

My problem is solved with another password having the same entropy and as I don't plan to create another account in the near future my interest is limited.