RGB Status & WS2812B


#1

I have a WS2812B strip I'm attempting to control using Rgb Status. So far no luck.

The pi user is in the gpio group.
SPI has been enabled.

The settings currently:

  • Type: WS2812_STRIP
  • LED count: 144
  • LED Pin: 10
  • LED Freq: 800000
  • LED DMA: 10
  • LED Bright: 255
  • LED Invert: Unchecked
  • LED channel: 0

Is Physical pin 19 the one to be using?

No luck with Physical pin 10 ~/pinout/pin10_gpio15


#2

I would say that "Pin 10" ist the number of the ten's pin. This must be GPIO 15


#3

Thanks for the reply!

https://pinout.xyz/pinout/pin10_gpio15

I tried that one also. No luck.


#4

you will run 144 led's whit this plugin


#5

That is the idea. They are NeoPixels.


#6

?
Now its working
If yes, what have you done?
:wink:


#7

They are not working... yet.


#8

Er are you trying to run the ws2812B strip directly from the RPI? Those devices are 5V logic levels, the RPI is strictly 3v3. You will need a level shifter if you wanted to connect a strip directly to the RPI. (e.g. https://www.sparkfun.com/products/14765)


#9

I calculated the type of switching power supply required just to control the 60 LEDs in the NeoPixel four-segment ring at 10A, 5V or about four times more power than the standard Raspberry Pi power adapter. You're going to need at least twice that for yours or 24A 5V power supply dedicated to just the LEDs.

24A 5V switching power supply


#10

D'oh! You are absolutely correct.


#11

I'm new... but not that new. :wink:

They are 12v powered by a 300 watt supply. I do appreciate the lookout. I can see how could be a gotcha.


#12

I was just about to put some basic white led strips in my enclosure when I saw this.

Anyone know what colors represent which status' of the printer?

It seems the plugin could have a little better description.

Are they commanded off when octoprint is in standby?


#13

Can you give some more details about what problem you are having? Are your leds turning on at all?

Another somewhat newbie question, but do you have the ground shared between the pi, the leds, and your 12v power supply?

You should be using physical pin 19, which is GPIO pin 10. https://pinout.xyz/pinout/pin19_gpio10


#14

They just don't turn on. The spec sheet says they require a 5v for the data line. Coming from Arduino I din't even think about the PI having 3.3v GPIO pins.

The PI's ground and the LED's have a common ground.

Thanks for clearing up the pin number! The numbering on the PI is a little nuts for someone new. :wink:


#15

Interesting. Technically the strips do require 5v logic, but usually the 3.3v from the pi works. I’ve never had to add a level shifter, but some people have.


#16

Guys, I spent a long time trying to get the NeoPixels to behave using a Raspberry Pi. It's really tricky.

Read through the multiple walk-throughs on Adafruit regarding the NeoPixel + Raspberry combination.

"Note that you might be able to get your NeoPixels to work without any level conversion, but it's not really guaranteed because the data line needs to be at least 0.7 * VDD (5 volts), or about 3.5 volts. Try one of the level conversion options below if you can't directly drive the pixels from your Raspberry Pi."

So if your Raspberry Pi has peripherals and is loaded down, the internally-available 5V may be slightly less. So if you ever see an undervoltage condition then give up trying to do NeoPixels without a level converter in place. I personally tried the diode-only version and I did not have success with that. And I used a 10A 5V switching power supply for the 60 LED ring and still this was problematic. I have purchased several of the logic level converters but I haven't returned to this project in a while.


#17

Interesting that your experience has been so different from my own. I’ve not used the Adafruit branded strips though so maybe there’s a difference there.


#18

Can you create an issue over at https://github.com/EricHigdon/OctoPrint-RGB_status/issues and share your OctoPrint.log there?