Save filename quirk


#1

Not sure if ever mentioned...I was able to once upon a time save my files as an abbreviated form
but once I set as "generic" then manually entered the build area and whatnot under Custom FDM Printer..it saves it as CFDMP_filename.gcode

I have two profiles setup one for Anet A8 and one for Tronxy X1...used to be AA8_filename.gcode or TX1_filename.gcode...it doesn't do that anymore...is there a way to have it save that way once again, or manually be able to tell it save with that prefix?


#2

If you slice inside OctoPrint, then the config.yaml doesn't seem to mention much in this area.

If you use Cura outside of OctoPrint, it's in the Settings.


#3

I do slicing externally...trying to slice a large file on a SBC with an older cura is woefully slow
My 8 core machine with 16 gigs of RAM and Cura 3.4.0 (haven't installed 3.4.1 yet) does it quickly

I guess I might have to make a project and use that...for some reason just loading a file seems to use the printer type rather than printer name...weird

I also may have not changed the "name" of the custom FDM printer at the bottom

I guess I'll take care of it on my end...thanks for the reply! :slight_smile:


#5

This "quirk" is in Cura, not in OctoPrint. The prefix was changed from being based on the name you gave your printer to the name of the printer type. It has been said that the prefix will be configurable in a future version of Cura.