SD Card Corrupted (I think) after attempt to find octopi login info

Hey there! I'm still a bit of a rookie at this stuff.
Since August I had been using a successful OctoPrint setup for my Prusa MK3. It was still working today, but I got a bit greedy.
A long time ago I bought a 7" display for my Raspberry Pi 2 B and never used it until December 2018, expecting to get a cool UI or something I could view from it. However, the glass layer on top had shifted after storage for a year and a half, so I couldn't see the last line of code on the startup screen. I made a thread on this earlier but with some help I answered my own question.
So, one day I was looking at the display from a weird angle and caught a glimpse of the last line. It said:
"octopi login:"
I tried the oldest trick in the book (pi, raspberry) and my OctoPrint username/password and nothing worked. By the way, regular OctoPrint still worked perfectly fine on my browser at this point. looked at other relevant threads on these forums and didn't really understand what I was supposed to do. I tried editing the cmdline file, and the wpa-supplicant file. Nothing changed. When I followed some instructions for putting the pi into "single user mode" ( the boot-up never even finished (didn't even get to the long stream of [ OK ] messages, it got hung up on recognizing the things plugged into the USB ports). I tried to remove the bit that that link above directed me to put in the cmdline file (I changed nothing else) and now I think I definitely messed up. Maybe it had to do with the "format disc" thing that Windows asked me to do before viewing the files on it? When I put it in the boot-up stream diverted from its usual [ OK ] messages. The last line was:
1.592775] --- end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(172)
I tried erasing the data on the card and reflashing the latest version of Octopi (0.15.1) using Win32 Disk Imager, but it keeps giving me a corruption warning and then "Error 5: Access Denied" when I try to write the file onto the card.

So, that's where I am right now. I'm stumped. It's also late at night haha. But I still have a couple questions:

  1. How can I reflash the OctoPi on the SD Card?
  2. What on earth is the login information for when the pi DOES boot up? And how do I reset it (because the pi raspberry trick doesn't work)

I probably forgot some, so if I remember more questions I'll ask on this topic.
I hope this makes some sense, and I can provide more information upon request.
Thanks for your time!

Yep. You shot yourself in the foot there. Windows was whining because it couldn't read the second partition on your perfectly-good microSD card (ext4) and then offered to "help" you by being pathologically stupid. Well, technically you did click that OK button but you were offered terrible advice from your operating system. (Microsoft/Apple could easily support the ext4 file system but they willfully choose not to.)

The default user/password on the OctoPi image (same as Raspbian) is pi / raspberry.

Follow the OctoPi document, starting over.

When you do a fair amount of customization on your installation (which is your time/effort/money) then do yourself a favor and backup your microSD in its entirety.

Alright, thanks for your help. I'm going to start over again now. It kinda sucks, but I had made a backup of the octoprint setup but I never downloaded it...

Just fixed it, thanks! Not sure why the pi/raspberry didn't work on the first version. After flashing with etcher (win32 disk imager had errors with "Access denied") it worked fine.

I have had nothing but issues with windiskimager32. I use nothing but etcher

And I've noticed that when your browser and/or operating system try to help you by automatically unzipping the image they can sometimes screw this up. Just download the zip as-is and hand it to Etcher.