Setting OctoPrint-PowerFailure Plugin with Prusa MK3S+


I installed the plugin OctoPrint-PowerFailure by pablogventura, but it doesn't seem to work well with Prusa MK3S+. Some edits in the configuration of the plugin are needed. Two main issues I'm facing:

  1. When the printer re-prints after a power failure, it prints within a few millimeters higher then the last layer prior to the power failure. I checked in the plugin settings and you need to edit the section "Z_HOMING_HEIGHT", but as far as I can tell there is no Z raise when homing the MK3S+. I might be wrong here though...

  2. After re-printing, the plugin doesn't wait for the extruder and hotbed to reach the desired temperature - it prints immediately without waiting.

If someone can help, or already have some good settings for the MK3S+ that works with this plugins,
I would love to hear from you.


The plugin was developed and tested on a Prusa MK3. It works fine.

You do not need Z_HOMING_HEIGHT set for the Prusa. It should be 0. The only reason why you might print a few mm higher is that you got unlucky and it was shutdown during a z-hop.

The plugin by default waits for the temperature to be reached before starting. See the 'Heating' section of the plugin settings. It will wait to reach the target temps before doing anything unless that section was changed.