Setting up OctoPrint on a Raspberry Pi running Raspbian or Raspberry Pi OS

No but I have had to setup 3 Octoprint installations on one network (only one was my personal one). Every time I setup Octoprint the worst of it is still messing with networking stuff. Octoprint-wpa-supplicant is a huge improvement over what came before it but getting wifi working right is still the most frustrating part of the setup.

I'm a long-time I.T. guy so I'm used to that part of the setup, to be honest.

Honestly, I bet I've gone through the OctoPi startup routine 30 to 40 times at least.

So I might just be missing something, but I got as far as starting the OctoPrint server- and the command prompt just looks like it can't finish what it's doing.
Recently wiped this old All-in-one and am in Raspbian right now, I just can't seem to get the server going

Sounds like you're going the manual route. Why not just use the OctoPi image? It's pretty easy.

Honestly, I hadn't thought to look at if Octopi was easily do-able on PC install... But I could use the learning experience.
Anything is going to be easier than the 17hrs it took to wipe the drive in the first place....

Currently, the only thing I can find that looks possibly wrong is that it shutdown the intermediary server.
I get a server heartbeat, it says this is the first startup event, and it registered the instance

Duh.... its octoprint serve....not octoprint. I guess I just needed more coffee

1 Like

Got diverted over here from Adafruit’s tutorial on getting Octoprint running with their 3.5” touchscreen. Followed the outlined steps in the original post, but after firing the command

/OctoPrint/venv/bin/octoprint serve

it runs through it’s thing, and then hangs. While the octopi image deffo works, since it installs the lite version of Jessie, doesn’t help with the touchscreen.


The route I took for two different Adafruit 2.8" screens was:

For the one with the Desktop version:

  1. Image with OctoPi and get that going
  2. Run the ~/scripts/install-desktop script
  3. Follow the Adafruit instructions for getting the screen running, choosing the option to mirror the Desktop rather than the console

For the one without the Desktop:

  1. Image with OctoPi as before
  2. Run the instructions from Adafruit, choosing the option to mirror the console

What's interesting is that if I do a ps -ax|grep octoprint I get:

 3033 ?        Sl     2:56 /home/pi/oprint/bin/python2 /home/pi/oprint/bin/octoprint serve --host= --port=5000

So my path collection is completely different than yours. I always use the OctoPi image route for installing.

1 Like

Derp. I'm a complete idiot and noticed plain as day the option to update to the GUI right there as soon as Octopi finished booting. This is what I get for trying this at midnight.

Thanks for the tips - I've got Octopi up and running, and the TFT module humming along using Adafruit's setup here:

Guess all that remains is to install the browser on the pi, and that should be it!

Pretty sure there's already a default browser in the Pixel desktop. I usually set the option to auto-hide the Taskbar at the top of the Desktop. I also "full screen" the browser and then it looks pretty good.

Combine this with the TouchUI plugin and you should be all set.

I corrected...thanks...created the scripts dir and added those files...thanks!

I also had to add my pi user to video in order to use V4L since I installed octoprint on Xubuntu 18.04

usermod -aG video pi
1 Like

Hello good Morning

I'm new to raspberry pi. come on.
I have a raspberry pi 3 and a lcd touch screen 5 '' and would like to know how to install the octoprint on it, to stay the same as this post.

I will be grateful to all who help me

Hello, i'm getting into some trouble with the install of octoprint. At first, everything was ok, i was able to get the web interface, setup everything until CURAEngine but at some point, i had to move my pi to another room and since then, i can't run octoprint anymore. I tried uninstalling but since, i can't even pass the "virtualenv venv" command, i get an importerror with the module 'importlib' normally i get my way around linux but here i'm clueless. If anyone have any idea ?


From this it sounds like you have 1) a Raspberry Pi and 2) you didn't use the OctoPi image. Start over from scratch, use these instructions and drive on. You're making this harder than it needs to be.

1 Like

Hi, thanks for your reply but i can't use the image, i have other stuffs running on my pi.

I've tried to the best of my abilities but I can not get my Logitech C270 working using these instructions.

Once I start mjpeg_streamer and go to its webpage, I get a page that never finish loading, nothing is displayed. The camera activates (light turns on) but nothing else.


I'm having problem at here. I can't access the OctoPrint's UI from my Raspi's IP. I accessed the OctoPrint's UI by the default configuration, which is "localhost/5000" in the browser. I checked line per line in the file haproxy.cfg and all are ok. I have access to start the haproxy and the octoprint. How can I resolve this?



I uncomment, removing "#", at the line of configuration file sudo nano /etc/default/haproxy. Like this:


It's working now with my Raspi's IP!

1 Like

is it possible, to install and start a second instance of octoprint.

i'm using Octoprint in an VM on a Linux Machine and the first instance of Octoprint is working fine.

I tryed it to install a second venv this way, but it does not work.

I also used the search function but i didn't fiind any solution.

Trying searching again with the word "multiple".