Settings Load Error

I have installed Octolapse and there didn't seem to be any issues during the install. However, I can't seem to get it to work at all. The tab is stuck on "Loading Octolapse..." and none of the settings work.

Every time I launch OctoPrint I am greeted with this message "Settings Load Error Octolapse was unable to load the current settings. Status: error. Error: INTERNAL SERVER ERROR".
image

I have tried uninstalling and reinstalling Octolapse and it didn't help. I have tried installing it through the plugin repository and through GitHub. That made no difference.

I would love to try more troubleshooting steps however when I try to do anything (edit main settings, add printer profile, restore defaults, etc.) nothing works and I just receive the same error.

I'm not sure if this is important, but I have OctoPrint installed on my windows pc since I have it on 24/7 anyways. That shouldn't be a problem though right?

'Internal server error' would be logged in the octoprint.log. I suspect that will have our answers to why this is caused, so could you upload it?

octoprint.log (439.0 KB)

Sorry, seems I missed replying to this issue - the forums have just reminded me of that!

I had a look in the log - the issue here is with Python 3.10 compatibility. OctoLapse is trying to access things that have been moved for a long time, and the old aliases were removed in Python 3.10. Using Python 3.9 should be OK. You should report this issue on the OctoLapse issue tracker so that it can be fixed, restoring compatibility.

2021-10-16 04:23:36,792 - octoprint.plugin - ERROR - Error while calling plugin octolapse
Traceback (most recent call last):
  File "C:\OctoPrint\venv\lib\site-packages\octoprint\plugin\__init__.py", line 271, in call_plugin
    result = getattr(plugin, method)(*args, **kwargs)
  File "C:\OctoPrint\venv\lib\site-packages\octoprint\util\__init__.py", line 1737, in wrapper
    return f(*args, **kwargs)
  File "C:\OctoPrint\venv\lib\site-packages\octoprint_octolapse\__init__.py", line 2362, in on_startup
    raise e
  File "C:\OctoPrint\venv\lib\site-packages\octoprint_octolapse\__init__.py", line 2311, in on_startup
    self.load_settings()
  File "C:\OctoPrint\venv\lib\site-packages\octoprint_octolapse\__init__.py", line 1999, in load_settings
    new_settings, defaults_loaded = OctolapseSettings.load(
  File "C:\OctoPrint\venv\lib\site-packages\octoprint_octolapse\settings.py", line 2406, in load
    new_settings = OctolapseSettings.create_from_iterable(
  File "C:\OctoPrint\venv\lib\site-packages\octoprint_octolapse\settings.py", line 2528, in create_from_iterable
    new_object.update(iterable)
  File "C:\OctoPrint\venv\lib\site-packages\octoprint_octolapse\settings.py", line 108, in update
    Settings._update(self, iterable)
  File "C:\OctoPrint\venv\lib\site-packages\octoprint_octolapse\settings.py", line 116, in _update
    if not isinstance(iterable, collections.Iterable):
AttributeError: module 'collections' has no attribute 'Iterable'