Solved: Ender 3 Pro, Creality Silent 1.1.5, Marlin 1.1.9 Octoprint 1.4.0 Connection issues

Dear octoprint community,
I’ve recently upgraded my Ender 3 Pro with the SKR 1.1.5 board with a BL Touch.
Sadly since this upgrade I cannot print reliably with Octoprint any more. I’m seeing errors like:
“Recv: ok
Send: N1047 G1 F2250 X98.922 Y141.349 E650.56694 10
Recv: ok
Send: N1048 G0 F11250 X99.488 Y141.349
Recv: Error:checksum mismatch, Last Line: 1047
Recv: Resend: 1048
Recv: ok”
Before the upgrade i had occasional blobs from the printer microstopping (discussed in another thread here, but at least prints were finishing.
I’ve done the usual, reinstall the Pi, change the USB cable, change the powersupply (3000 mah). I don’t see undervoltage issues.
I've also increased serial buffer from 4 (standard) to 16, but it did not cure the issue. SD card printing works great all the time, only Octoprint causes errors which ultimately make the printer reboot.
I’ve uploaded serial log (error f.e. line 2448) & octoprint logs (error f.e. line 1166) here: Octoprint logs
I've also worked through the other posts here and tried all the fixes in there.
Here is my configuration:
Printer: Ender 3 Pro
Board: Creality Silent 1.1.5
Firmware: Marlin 1.1.9
Baudrate: 115.000
Serial Buffer: 16
Controller: Rasberry Pi3b+
Octoprint: 1.4.0
Puglins: Bed Visualizer
Usb cables: various
Storage: USB HDD
Webcam: Yes
Power supply: 3.000 mAh

I’m honestly a bit lost what to try next to get Octoprint stable again as it is a great too.

Thank you very much for your help!


Are you sure? Didn't you mean the creality 1.1.5 silent board?

Yes, sorry, it was early in the morning!
I corrected it. Thx!

I would try a simple thing and test of it changes the amount of checksum errors:
Cover the mainboard box in aluminum foil.
I noticed that my older non silent creality mainboard is very sensetive when it comes to electromagnetic interference.

Thank you, I will try this.

After a lot of trial and error and no results I got an SKR Mini E3 1.2 and all comunication errors were gone.

1 Like

Great! Could you please: PSA: Please mark the solutions to your topics as such

1 Like

Is this solved? It seems a different board solved it, but that other board might be using different firmware from the skr mini . I wonder if the fact there is an Marlin 1.1.9 bugfix version, and the bug has something to do with prints stopping might be involved here? I'm interested because I just updated to the 1.1.5 creality main board and a was planning to get BL touch at some point which might mean updating the firmware. Would be nice to know if anyone else had the same problem.

FWIW Marlin (the firmware Creality and BTT use) is on 2.0.x. Weather BTT bothered to upgrade I don't know.

Hello, my problems might have been due to a faulty connector on the Creality board. However I can only strongly recommend the SKR board.
The printer runs so much smoother with that board. The value for money is impressive.