SOLVED: Raspberry Pi 2B Wifi Issues with Buster and Octopi

Continuing the discussion from WiFi setup and troubleshooting:

Hardware: Raspberry Pi 2B, TP-Link Wifi Dongle

Issue:
Raspi-config was "unable to communicate with WPA_supplicant" on setup for both vanilla Rasbian Buster and Octopi (both most recent as of 2020/03/08). I encountered this same issue on Rasbian Stretch in the past as well, and the solution was the same.

Solution

Edit WPA_Supplicant and network/interfaces like so.

sudo nano etc/wpa_supplicant/wpa_supplicant.conf

country=CA

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="**SSID**"
psk="**PASS**"
}

sudo nano /etc/network/interfaces

auto lo
iface lo inet loopback

iface eth0 inet manual

auto wlan0
allow-hotplug wlan0
iface wlan0 inet manual
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

And then: sudo systemctl enable wpa_supplicant.service

Thats it, reboot and rip it

More about this issue:
I knew something was amiss when I ran sudo iwlist wlan0 scan and was able to see all of the networks. The issues with WPA_Supplicant and interfaces files were cryptic and I had to stitch together lots of hints from different forums to solve this.

BigFin you made my day.
thank you very much. your solution did the job
Regards
René