Specific plugins not showing up anywhere/ permanently disabled

Howdy, I’ve been using a Raspberry Pi 4 8gb for Octoprint for about a year now, and haven’t had a problem until now. I recently decided to put a filament sensor on my printer and tried downloading the “filament sensor simplified” and it after I did it said it downloaded “unknown” successfully, but when I went to the plug-ins menu it was not there. After that, I went to “Plugin Manager” and looked at all the plugins I have installed and it wasn’t there either, so I assumed maybe it had an error and restarted the Pi. Unfortunately, this did not fix the issue, and it was still invisible. I figured at this point that maybe it never downloaded in the first place, so I downloaded it again, but in the downloading process, I said “ successfully replaced filament sensor simplified-0.3.3 with filament sensor simplified-0.3.3” implying that it was already downloaded (but not visible anywhere.) so figured I’d try “Octoprint-Smart-Filament-Sensor” which downloaded saying successfully downloaded “ Octoprint-Smart-Filament-Sensor” but when I went to the plug-in menu, it was not there… so I checked Plugins Manager where I found it in the disabled category, so I tried disabling it but not matter what I tried, it wound allow to enable it… any thoughts on what might be wrong?

Hello @Supermac05 !

Besides you use a RasPi 4 and that you want to install a filament sensor plugin, we know nothing about your setup.

Please share the systeminfo bundle in your next post.

sorry about that, it won't let me send the file...I think this is what you need...

browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/12.1.2 Safari/605.1.15
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1500.0
env.hardware.ram: 8228380672
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.8.1-20220524101555
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.last_safe_mode.date: 2022-10-01T17:01:05Z
octoprint.last_safe_mode.reason: settings
octoprint.safe_mode: False
octoprint.version: 1.8.4
printer.firmware: Marlin Ver 1.1.1
systeminfo.generated: 2022-10-02T00:40:34Z
systeminfo.generator: zipapi

Sorry, but:

I fixed it

And how?

Maybe some other users are interested.

All I did was clear Octoprint off the micro SD card and start from scratch. Then the first plug-in I downloaded was the filament sensor simplified…

1 Like