SQ11 1080P (actually 720P) webcam *working* thru non-standard software [FAIL]


#1

I managed to get a cheapo "claimed to be" 1080P, (more like 720P) SQ11 working on an Orange Pi Lite,
I had to use a hack/tweak I found on a french site

https://www.ordinoscope.net/index.php/Informatique/Softwares/OctoPrint/Webcam_USB/SQ11-SQ12

per the site
Configuration:
This webcam is not fully UVC compatible, and the driver must be loaded with the workaround option

sudo modprobe uvcvideo -r
sudo modprobe uvcvideo quirks = 2

/etc/modprobe.d/uvcvideo.conf

options uvcvideo quirks = 2

The old uvcvideo driver supplied with the Raspberry Pi is not as compatible as the newer ones. The resolution seems limited to 1280x720 @ 30 fps, which is very suitable for this purpose.

/boot/octopi.txt

camera_usb_options = "- r 1280x720 -f 30"

This configuration has the advantage that mjpeg_streamer consumes very few resources (10 ~ 20% of a core), much better than YUYV.

I did have to change the command...and remove the spaces
sudo modprobe uvcvideo quirks=2

It works...I added the /etc/modprobe.d/uvcvideo.conf
file, but it still doesn't work on reboot :frowning:

Might have to put it in the rc.local to get it to do the removal and the read with the quirks option turned on

Currently printing a mount arm and case I modded in tinkercad so I can try to do some timelapse recording...not the best option...but for less than $12 it seemed like a great way to go

I also did have to build the webcam build of the experimental mjpg_streamer to get it to work


Webcam:
If you also want webcam and timelapse support, you'll need to download and compile MJPG-Streamer:

cd ~
sudo apt-get install subversion libjpeg62-turbo-dev imagemagick ffmpeg libv4l-dev cmake
git clone https://github.com/jacksonliam/mjpg-streamer.git
cd mjpg-streamer/mjpg-streamer-experimental
export LD_LIBRARY_PATH=.
make

Still tweaking/testing...but it does display on the octoprints webpage and currently recording a not so good timelapse (it's taped on my TronXY X1 arm...heh)


#2

Well crud, after rebooting, no go...will have to go thru again and see what I did to get it to work...then make it permanent and activate on startup...

Then do a writeup


#3

Ok...could NOT get mjeg-streamer working to save my life...nope..nada
Even tried doing a ffserver but couldn't get it configured correctly

Ended up going a different route
Downloaded and compiled a program called cam2web and what do you know it works!


apparently it should work with almost all USB webcams and even the RPi camera

Here is a link to my binary and the tarballed up compile directory if you want to check it
https://mega.nz/#F!6RtD3SJC!5ULJ4FMyDm153I-YAQn7mQ

I generates it's own webserver, and all I had to do is simply plug in the link to the images in the timelapse blocks and viola...it just worked..first try...no tweaking, coding, fiddling...

Check it out..might be another way for folks to have cameras on their builds with non-standard devices


#4

Hi mate you would by any chance have a guide to getting this to work on the pi? ive been trying for ages and just cant get it working at all


#5

actually I ended up trying over and over...then my sdcard died on me...finally gave up on dietpi, currently re-imaging using straight armbian on an Orange Pi Lite (and that in itself is giving me fits..but finally have it talking solidly thru wifi)
I ended up going with a plain jane cheapo webcam for my camera...this one works great...the other one...no matter what I tried...could not get it to stay up after a reboot


#6

Ah ok, cheers for getting back to me on it, looks like ill just use my webcam

Its a shame really as the sq11 is great for the price and is small enough to be out the way