SSH denied to root logging in to Octo4a on Samsung Galaxy Note8

What is the problem?

Running Octo4a (OctoPrint for Android) on my Samsung Galaxy Note8 phone. Everything has been fine and working perfectly. I just discovered that I can SSH into the phone from Windows and got that working as well for root. After adding the line "AllowUsers admin" to the /etc/ssh/sshd_config file to allow access, I rebooted the phone. Now when I try to SSH in as root I'm getting "permission denied". I can't log in as admin either. Since I can't get in, I can't undo the changes I made. I tried resetting the password in Octo4a and rebooting again, but no joy. Is there something else I can do to reset it? I don't "require" SSH access, but it was nice to know I could do it if I needed to. Any assistance would be appreciated. Thanks in advance!

What did you already try to solve it?

I tried resetting the password in Octo4a and rebooting again. I disabled SSH access in Octo4a and reenabled it also. No change, still denied. I cleared the password, same.

Have you tried running in safe mode?

No. Octoprint itself runs just fine.

Did running in safe mode solve the problem?

See above.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20220108204636.zip (18.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.7.2
Running Octo4a build 1.0.4 (Alpine Linux) on Samsung Galaxy Note8
Ender 3 v2
JyersUI v2.0.1
Chrome
Windows 10 21H1

If you don't get a better answer - just delete the app data. That will reset Octo4a.

and for the future - please don't ask the same question in different threads :slight_smile:

Thanks for the response. Can you be more specific about the folder name and location? I don't want to lose all my OctoPrint plugins and configuration, if possible.
Sorry about the duplicate post, first time using the forum. I didn't know if they went to two different places. I'll remove the other post.

Oh I meant resetting the complete app which of course also resets everything Octoprint related.

Sorry I can't tell you if there is another way to get into this vm.
You could try to ask that question on the projects github page

I see. I was planning to move to another phone eventually, so I'll do that sooner rather than later. There is a backup and restore function in OctoPrint so maybe that will save me some time. Thanks for the assist!

1 Like