πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Standard Release might have a problem in it

Hello,

I am new to 3d printing, my printer was acting up on SD card, so wanted to check if I could run it via USB. Decided to go the Octoprint route. Ran into a slight issue.

I downloaded the standard distro, extracted it, and tried to flash it using etcher. It said flash failed. After this happened on four separate SD cards, I tried to open the zip using PeaZip and Peazip locked up. Same happened with 7-zip. Downloaded again, same result. So far I thought I had done something wrong. Used a different flash program to verify the flashed card, it gave the same verify failed message on the same sector for all the cards.

Then I tried the nightlies and download the version from March 2nd, 2021. Followed the same steps, and Etcher flashed that successfully the first time around, onto one of the same cards.

So I think the currently available distro might have something wrong with it. If you can give it a look, it might save others some hassle.

Thank you for your time.

The download page has an MD5 checksum so the first thing to do is compare the MD5 checksum of your download with that posted on the page. You can get an MD5 checksum program from https://sourceforge.net/projects/winmd5sum/.

Assuming the checksum is correct try Etcher again. Etcher is, IMO, a very flaky program. Sometimes it works and sometimes it doesn't. If it fails a couple of times in a row, use 7-zip to extract the .img file and win32diskimager to write the SD card.

I also find that the official Raspberry Pi Imager works a lot better than etcher does. Problem with changing the install guide to recommend RPi imager was that it gives a bunch of preset images and you have to dig to find the option to use custom.

It's code is open source (I know this is off topic), but if anyone Qt familiar wants to make an OctoPrint branded one...

Thank you both for the suggestions. As I mentioned, I used the nightly build image, and got a good card. I have Octoprint installed and running and have been able to get the server up and running, so it does not really affect my options at this point.

or we could get the octorprint added similar to plex etc.
or maybe just make a shortcut etc to start using: --repo [your own URL]

Its all stored here: https://downloads.raspberrypi.org/os_list_imagingutility_v2.json but i can't find any docs on how one gets added to this list.

Actually, I like the idea of having the distro come with its own card imager, but the question is who would do it. I certainly don't know how to write that code. So I am definitely not going to ask that someone do it :slight_smile: If someone decides to supply one, out of the goodness of their heart, I would definitely applaud their effort. Not familiar with the plex option, so can't comment on that.

BTW, on that note, my thanks to the authors of Octoprint as well as the moderators of this forum for their time and effort.

@b-morgan: I did try use the Win32diskimager utility to create the card. It initially told me that verify failed against the cards. When I tried to write the image to that card again using that utility, it locked up, hard enough that I could not even kill that process. Had to reboot to get rid of that window. It is not often I've had that experience.

1 Like