Stepper motor not moving; nothing extruding *resolved


#1

When I start my print the stepper motor is not moving any filament through, so nothing is coming out of the nozzle. I tried a few times, and it's not moving. There is no clog in the nozzle, it's just not turning.

I checked to see if Octoprint would extrude filament through the Control tab, and it does. So I'm not sure why during a print, it won't extrude anything.

I'm currently running OctoPrint : 1.3.10 with Octolapse 0.3.4. with my Ender-3 Pro on a raspberry pi 3b. I just got Octolapse set up with my DSLR so I'm pretty bummed that when I start a print it isn't working! This is my first time trying to print with Octoprint.*

Edit: Actually second time. I did get a print started that used an STL from Canvas. I'm wondering if the issue is maybe I'm trying Cura 4.0 for the first time? I'll try using the older Cura and see if it works. I don't see why this would be the problem, but worth a shot I suppose.

Any help with this is appreciated, thank you.

Resolved. Octolapse was set to test mode. My bad.


#2

There's often a minimum temperature threshold before extruding. On mine it's like 170C or something like that. Just verify that everything is, say, 175C or better before trying to extrude/retract.

You indicate that it appears to behave if you use the Control tab to jog things there.

First things first, when you turn on your printer and fire up OctoPrint, you should HOME the X/Y and Z axes. It's probably a good idea to add the gcode for that into one of the scripts in Settings -> GCode Scripts early on.

Typical slicers at the beginning of your gcode session will set the absolute versus relative movement modes for axes and extruder(s), home things, reset things with a G92 to mark "zero" and then start heating things up.

Copy/paste the first 30 lines of the gcode file here. Do the same for any GCode Startup scripts you find in OctoPrint's Settings.


#3

The first 30ish lines from the file's gcode are here:

;FLAVOR:Marlin
;TIME:4536
;Filament used: 2.95809m
;Layer height: 0.15
;Generated with Cura_SteamEngine 4.0.0
M140 S60
M105
M190 S60
M104 S200
M105
M109 S200
M82 ;absolute extrusion mode
; Ender 3 Custom Start G-code
G28 ; Home all axes
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
; End of custom start GCode
G92 E0
G1 F2400 E-5
;LAYER_COUNT:281
;LAYER:0
M107
M204 S5000
M205 X30 Y30
G0 F3600 X103.697 Y90.885 Z0.2
M204 S500
M205 X20 Y20
;TYPE:SKIRT

#4

There is nothing in the startup gcode in Octoprint.


#5

I take it that it doesn't draw two lines in the beginning?


#6

It does not, no. It goes through all the motions, nothing comes out.


#7

I've found that if the z-offset is off (and the hotend is basically smashing into the bed) then it really won't extrude and will end up clogging the hotend.

Each time you start a print you should get into the routine of extruding about 5mm or so of filament since it's probably been sitting there in the hotend for some time and probably isn't all that great anyway. What happens if you manually heat up the bed and hotend in the Temperature/Control tabs of OctoPrint, extrude about 5mm of filament, use some tweezers to remove that and then start the print?


#8

As I mentioned, it's not clogged. The stepper motor is not actually turning, or attempting to turn, to pull filament through. I know the sound and what it looks like when it's clogged, and this isn't the issue.


#9

But it extrudes from the Control tab. Just not from the print job.


#10

This is the case, yes.


#11

If it were me, I would manually enter each line from your gcode file one at a time, watching the result.

I will note that my printer manufacturer (Robo 3D) didn't really know what they were doing at times and would have competing abs/rel movement modes going on in such a way that their priming line would result in the first 10mm of your job being starved of filament.

It's possible that you have an extrusion audit issue.

Say for example that it's in absolute extrusion mode and a G92 E0 has also been issued. And then there's some custom script that's been inserted where it does something interesting and yet throws off the extrusion audit. This would affect the lines which follow that: 1) either it ends up blobbing up a great mess of filament or 2) it gets stingy and doesn't lay down any filament until that audit has been caught up to again.

Try something different: Go into Cura, slice again but this time turn on RELATIVE EXTRUSION.

55%20PM


#12

Just tried it now. Still nothing :frowning:


#13

Alright. OctoPrint -> System menu -> Restart in Safe Mode and see if anything's different. Maybe OctoLapse or another plugin is interfering.


#14

Ok here we go! I turned off Octolapse for this print, and it's working. So it's Octolapse.


#15

Aaaaannd now I see why I should read instructions fully. I was following the setup for Octolapse, and it was set it "test" mode but I neglected to see where it says it won't actually extrude during test mode... Doh...


#16

Awesomeness.


#17

Thanks for the hand holding :slight_smile: I appreciate it!