Stop messing with my gcode


#1

I'm interfacing with an Tronxy X5SA. When I embed an M0 in my gcode and a specific layer, and print from the control board SD, it works fine. The printer pauses moves the Z axis down, and moves the extruder to home for a filament change. When I resume, it goes back to where it left off at the proper Z height. However, if I print it from Octoprint, it pauses at the current location and sits there. I must have something configured in Octo that causes it to intercept certain gcodes and do something else with them. Argh?

Regards,
-B


#2

octoprint parses M0 as pause
since 1.3.9 version you can turn this behavior off:
#1513 - Option to allow sending M0 / M1 to the printer instead of swallowing it.


#3

Thank you Arhi for your response. I was ready to trash Octo, but now I'll revisit tomorrow and try again.

Regards,
-B