Touch screen x + Y reversed


What is the problem?
I have a 3.5 restive screen working great except for the touch part. The axes seem to be reversed.

What did you already try to solve it?
Tried solution in the SETUP:Trouble shooting guide. Did calibration worked, put section in /etc/X11/xorg.conf.d/99-fbdev.conf

Section "InputClass"
        Identifier      "calibration"
        MatchProduct    "ADS7846 Touchscreen"
        Option  "Calibration"   "3936 227 268 3880"
        Option  "SwapAxes"      "1"
#       Option "InvertX" "true"

I have tried various versions of this file changing the swap and invert options.
Internet had a few articles on it. No go.

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Octprint Version 1.3.9


Have you tried "0" there instead of "1"?

Honestly, though, download and run Adafruit's script.


Please format your log files in the future.


SwapAxes will do just that- X becomes Y, Y becomes X. It's hard to tell if that's what the OP is saying (to me, at least).

If X and Y are inverted, these options should work:

    Option "InvertX" 1
    Option "InvertY" 1

via a series of answers on stackoverflow


I tried that first. I also tried Adafruit and that screwed up the system somehow but I'll try that again thanks. By that point I'd probably tried several things. I have back up right after getting touch to work, I'll go back to that and try it


I've used two different methods. I have one each of the resistive and capacitive style of TFTs, probably 2.8" on both. The Adafruit installation method is by far the easiest.


This is SO frustrating. I'd love to know what I'm doing wrong. I spend the last day and a half trying different approaches. I agree that adafruit is super easy, but it leaves me with a white screen, IE drivers not loaded according to the guides. I tried Adafruit with a clean install of octoprint. When using the github method, I get the touch UI but x & y are inverted.

I was wondering if it's the hardware, but I have two different units that have different motherboards and both of them work except for xy.

At this point, I'd be willing to pay someone $20 to help me work thur this. I have access to gotoassist if needed.

What's super frustrating, I have a Jessie boot disk (not octoprint) and I use it exclusively with "SD card copier" to back up disks. Without configuration, it just booted to the touch screen, the calibration is dead on.