touchUI menu issue (TP-Link plugin)


Hello everyone.
i'm running Octoprint on a Raspy 3 + 3.5" LCD for some time without any issue.
After the last updates, a few days ago, i have a big trouble with touchUI plugin.
The menu on the right is incoherent, full of ??????
The problem appears only on the 3.5" screen attached to the pi not on my computer nor my smartphone.
So i've tried to set a higher resolution but this doesn't solve the problem and everything was fine before.
In order to debug the problem i've removed all the third party plugins and activated them one at a time.
Finally it appears that tplink plugin causes the issue now. But i had the same problem some months ago with another plugin, don't remember which one exactly.
I could deactivate tplink plugin as i did for the other one but i don't want to apply this solution.
Change the screen size ? Sure but it works fine.
So as this is not the first time i have this problem and i think it won't be the last one, does anybody know if there's any workaround that could be applyed when touchui goes crazy with another plugin ?


If this were me, I would install VNC and view the LCD remotely from my own computer. I'd then right-mouse click on the screen and review the Developer's Console to look for any JavaScript errors.


Hi thank you for the suggestion.
I've tried it and the problem is the same with vnc.
I cannot access developers console, i suppose there's none in epiphany browser.
I can see something related to tplink wrapper between tplink menu and settings menu.
Maybe is this the problem.
Without touchUI everything works fine.


As developer of the TPLinkSmartPlug plugin I can take a look to see what might be happening with TouchUI. The question marks you are mentioning make it sound like a possible fontawesome related issue for the icons, but without getting any kind of screenshot of the issue, it's hard to tell. Can you use the VNC to get a screenshot of the menu for me and post as an issue over here?


And you might be able to install the Chromium browser on the Raspi which may support a Developer's Console.


Sure, i have a two pictures that show the problem. I send you them immediately.


I found the solution.
It relies on epiphany browser capabilities. I've tried firefox and chromium and everything is fine now.
More details here.