TP-Link Smartplug unable to add or edit a new plug

After updating to the latest Octoprint 1.3.11 I am unable to add or even edit my TPLinks smart plug.

I have tried to uninstall and re install the plugin, but nothing has improved.

Some files may have been corrupted (my humble guess).

Any suggestions is appreciated.
Thanks all in advance.

Try connecting to your pi via ssh or with a keyboard and monitor plugged in and run this command.

nano ~/.octoprint/config.yaml

Then delete the tplinksmartplug section completely from the plugins section of config.yaml. Then restart octoprint and add your plug(s) back.

It worked.
Thanks for your prompt response

Cool. I still need to figure out why this is happening. I think it might be related to the addition of thermal runaway option that I added, but haven't been able to dig in deeper.

Don't forget to mark it as the solution to your post....

Thanks for letting me know, I wasn't aware of the "Solution" tick box.
And also, thanks for the useful plug in...