TPLink Firmware Updates Breaking TPLinkSmartplug Plugin

WARNING: Several recent reports on my issue tracker have indicated that TPLink is locking down their firmware with recent releases and as a result the TPLinkSmartplug plugin will no longer be able to control your devices. It was a fun ride while it lasted and I will continue to support the plugin the best I can but if you are looking into IoT based power control you may want to consider a Tasmota capable device instead.

I was just coming to ask why the plugin was no longer shutdown my printer. Darn, that sucks.

Agreed, it's caused several new issues in the repository. Could you let me know what model, hardware version, and firmware version is listed in your device's info in the Kasa App please?

I am using HS100 plugs, hardware 2.0 firmware 1.5.6. The Kasa App is version 2.22 build 794. What is interesting is I can still turn the plugs (I am using two plugs, one for the printer and one for heating my chamber) on and off via Octoprint with the little lighting bolts at the to of the web dashboard, but my printer will no longer shut off or the heater will not shutoff below my set temperature in the shutdown printer plugin. I haven't changed anything and it stopped working a week or two ago.

If you can still control via the navbar button then it could be related to the Shutdown Printer plugin, I don't know. All of the features that were in that version have been integrated into the TPLink Plugin (Idle Timeouts) so I don't see why you would need the other? Maybe try disabling that plugin and utilize the built-in Idle Timeout.

How do you set up the TPLink plugin to shutdown when the printer is below a certain temperature? Never mind, figured it out. Didn't read close enough. I will give this a try and see if that works.



I turned on my printer and heater and let the hot end heat up a bit and then turned off the temp. The printer and heater plugs did not shut off when the temperature went below my set temperature of 75 C. I don't know if this is a valid test or not or if I need to run a print and see if it powers off then.

Any other thoughts on what to make the plugs shut off automatically and not via toggling them on the dashboard?

Make sure you saved your settings after making the changes to the plug, and also sometime restarting OctoPrint will shake things loose. Don't forget their is also a Idle Timeout value that it won't start to even try until that timeout is reached.

I just saw you updated the plugin, so I let it update and will do a small print and see how it works.

After rebooting my pi and printing a small print the plugin didn't shut the printer down at the set temperature. Here are my settings

What about the individual plug's settings? There they are.

And you waited 30 minutes?

No, I thought it would go off once hitting a temp of 75, so it must be below the target temp and past the idle timeout? I will give it a go and change the idle timeout to 2 mins and get back to you.

Yeah, it's the timeout that comes first, and then makes sure the temp is dropped before shutdown.

It worked!!! Thanks for working through this.