Tplink upload power on with Prusa MMU2

I am using the Tplink plugin to control the power of my printer, and have set the Octoprint configuration within Prusa Slicer to allow sliced prints to go straight to Octoprint.

Once Octoprint receives an upload then via the Tplink plugin it automatically powers on the printer - and usually then starts the print.

The problem I am having is 1) Sometimes the print doesn't start - and I have to go into Octoprint to kick it off
2) WIth the MK3s connected to an MMU2 I am finding that Octoprint is sometimes starting the print too early - before the MK3s has recognised that the MMU2 is present.

Is there any way to delay the start of the print for a few seconds after the printer powers up and auto connects as I think this would solve both of my problems.

for 1 we need logs or we don't know what's going on.
for 2 you could try the G4 gcode in your start gcode


Thanks PrintedWeezl - I added a 20 second delay at the start of the GCode and that seems to be long enough for the MMU2 to be detected after Octoprint initiated power up - Tried 5 and 10 seconds first and it wasn't long enough.

G4 S20; Dwell for 20 seconds to allow MMU2 to connection to MK3S are octoprint auto power on
M862.3 P "[printer_model]" ; printer model check
M862.1 P[nozzle_diameter] ; nozzle diameter check

You could also adjust the connect delay in the plugin's settings.

Jneilliii - thanks for the suggestion - however you seem to get another reset after the increased auto connect delay- then once the connect is complete octoprint then starts sending GCode straight away.

The G4 solution seems to work - the only problem with it now is that every print will have to delay 20 seconds - including those where the printer is already on.

Might just try removing the printer model check - or maybe just move it after the bed heating step - as that should give plenty of time for the MMU to sort itself out.