Trying to get my head around Access Control

Searched first - found the question - did not find a solution.

I am running the latest stable 1.4.0

I have my admin account set up and no issue. I pretty much want to set up a view only account for a buddy.

One would think it as easy and creating an new user and putting him in the Read-Only Access group......

The issue is octo forces me to keep him in the "users" group because it is set to the default.

So I delete the user. make the "read-only access" group the default and the user still has permissions to delete files etc etc. I look and he is also part of the "user" group and I cant uncheck the "users" and "read-only" doesnt seem to over ride the "user" group.

soooo....then I choose NO default group. and can not just assign the user to the Read-Only group.

I even tried creating my own it the permissions I wanted and still no luck.

It cant be this hard.

How can I give someone a user accnt with true read-only access?

You wait until 1.4.1 is released stable (current plan: tomorrow) because that contains a fix for that, or you update to the current RC right away.

1 Like

Thank you thank you!

Just glad to hear its not just me!

I can wait for 1.4.1....looking forward to it actually.

This will be a perfect test bed for testing it too (not my primary printer)

Thanks foosel!

installed 1.4.1 right away and all looked good. I created a read-only user and then i logged in as that user. All looked great. Then I hit the themefy button to see what it would look like on mobile. and now Im stuck as that user and unable to turn off the UI touch in themify.

I rebooted the octo server and cleared the browser cache. Im still getting logged into themify as the read-only user and I appear to have no recourse. Cant even restart octo in safe mode.

Can someone please advise how to i guess kill the themify plug in so i can reboot and log in as myself?


Easiest? Open browser in private mode, log in as admin, do the needful.

Alternatively, there are other ways to get into safe mode, the menu is only one option. Hit the link.

Thanks foosel - I felt as though I painted myself into a corner on this one. :wink:

OK - I have gotten out of that mess! Thanks again. It would appear it was TouchUI that messed me up - not Themeify.

Once I entered TouchUI as read-only user there was no way to turn it off or log out.

There's a release pending for TouchUI that fixes the issue of not being able to get out of 'touch' mode, with 1.4.1. Have sent a message asking when this will be.

1 Like

Thanks dood - that is awesome! Im gonna keep it turned off until then.

1 Like

I can log on as the Read-only user from my main machine...but any other machine the octo login interface just like refreshes and back to the log on screen.

even tried from 2 cell phones the read-only user wont log it...