πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Trying to get TouchUI, GUI working on Raspberry Pi 3B+ and 7 inch Screen

What is the problem? 1st loading to GUI.

What did you already try to solve it? Many hours surfing web topics and trying various methods mentioned in forums and website

Additional information about your setup OctoPrint version 1.3.10 OctoPi version 0.15.1 Printer(s) Original Prusa MK3 MMU2 & MK2.5, Raspberry Pi 3B+ V1.3

Hello all, first post here and im having some real difficulty trying to do what i wanna do with my unit.
Back story: Purchased a new Raspberry Pi 3B+ kit with NOOBS, 7inch Element 14 touch screen. Goal was to make a 7 in touch controler for Both my Prusa printers. Having 1 pi for 2 machines was original goal with 2 octoprint servers running simultaneously.
Initially just want to have 1 printer and 1 session running as a test run on the unit first as i have a pi zero w on the mk3 already.
Tried @foosel setup guide to install octoprint with the Raspbian OS (stretch i think it was, was the full OS install from NOOBS) so that i could keep the full OS and be able to run octoprint on same unit.
Failed at that guide at the basic info stage.
Cant remember exactly what happened but i think i keep getting a mkdir not found and 1 more.
So i decided to go with an OctoPi install as, in reality, i just wanna print with it and didnt need the full OS install.
I have installed OctoPi and can access it from my desktop/laptop/tablets browser and seems to be working as normal as the addons i DL for octoprint.
My thing is i want to be able to use my 7" touch with touchUI to control my printer session.
1 Thing i have tried is to boot to GUI option in the
sudo raspi-config --> 3. Boot Options --> B1 Desktop/CLI --> B4 Desktop Auto (also tried B3 as well)
First was giving me error and stated i needed the lightdm install. so i did sudo apt-get install and let it run its thing.
afterwards i did the reboot.
(i also have done the desktop script that shows in the CLI when it boots up as well, as well as the get updates)
each time i reboot it, its just the CLI and doesnt boot to desktop. so im confused lol. i ran the script it showed me and did the lightdm as well.
That desktop script doesnt show on my CLI anymore, and the info it shows my is my address to log into octoprint and my version numbers.
Again Octoprint does work and i can access it from my desktop, as well as SSH into my Pi using Putty so i dont think i messed up there.
After staring at my screens for past 3 days trying to figure this out hurts my head, not to mention i have no experience with linux based stuff, but have at least been able to get half of what i want to do done lol.
about ready to wipe and try reinstall fresh again in case i keep screwing something up.
if you want any other info ill do my best to get it for you, i dont know how to call up the log files from the pi though so if that is needed ill need someone to hold my hand and walk me through that part lol, sorry

Read through this (especially the Overview section at the top). The second bullet means "sudo ~/scripts/install-desktop` which you should run to add the PIXEL/Desktop/X windows system to the standard Lite version.

For the third bullet, if this is the Raspberry Pi Foundation 7" screen you might not have to do much else. It may just work out-of-the-box.

You do want to use sudo raspi-config to boot to the GUI automatically as pi.

There's a kiosk argument for Chromium that may save you some adjustments. Look to this page and concentrate on the portion toward the bottom where you're editing the Desktop configuration file.

yea ill give that a read through as well.
part of this is what was confusing me because i did do the sudo ~/scripts/install-desktop and thought that was the solution but nothing happened afterwards.
as i mentioned im a total noob at this stuff and probably missed something that someone experienced knew what to do . Figured that after i ran the scripts and did the boot to GUI option i wouldve been all set.
But since i havent read that link you gave me yet ill go do that now and come back with my results.
Thank you for responding, Ill be in touch shortly

ok @OutsourcedGuru, now that im done doing family duties with my kids i can do this thing lol. and i wanna say thank you again for your help. the desktop script you gave me worked perfectly. the one that was in the CLI was not working at all.
started with something like /home/something here/scripts/install-desktop that was a few lines above the first entry line to enter user and pass.
the sudo ~/scripts/install-desktop worked great and also allowed me the option to go ahead and boot to desktop without having to use the sudo raspi-config setting.
so thats 2/3rds accomplished on what i wanna do, next is to look to install a browser and touchUI onto the unit.
and as a mention about the touch screen im using, yes its the official one, i mentioned element 14 as that was the vendor (written on box), was a nice set up too as it already had all hardware and the board installed and all i needed was to install ribbon cable and run a power cable (a y splitter was provided to allow for 1 powered swtich to provide power to both pi and screen) and it was plug and play into the raspberry pi 3b+, and since i got the screen stand and bracket for it didnt have to worry about flipping the screen or finding where to mount the pi (Smarti Pi Touch) super nice too cause still can attach hats to pi if i ever felt like it and has a desktop stand or a wall mount bracket for mounting unit.

like i mentioned next is to do a browser and get touch ui installed. (not just the touchUI for browser, but i want the whole display to be a touchUI, not sure how to do that yet)

in the near future id like to know how to do 2 seperate octoprint sessions to have 1 Pi to run 2 printers to get my MK3 off the sub par pi zero w unit thats currently hooked up to it (and causing issues), but thats the near future.

Thanks again for the help, back to forum surfing and tinkering!

HAHA got it working how i wanted it to, yay!
Took a few days of beating this brain against a wall then some most invaluable information from @OutsourcedGuru.

So here is my summary:
Quest objective: To install needed components to run Touch UI (fullscreen) on a new raspberry pi 3 b+ and a Pi 7 inch touch screen.

Problems i had were that it was not loading to desktop (which i wanted)
was using the script to install desktop that was displayed on my unit. Failed
Followed script supplied by @OutsourcedGuru which was sudo ~/scripts/install-desktop

After I was able to install desktop and configure boot to desktop (option for that was given to me as part of the script so there was no need to go to sudo raspi-config)

Next quest was to install chromium sudo apt-get install chromium-browser --yes worked

Next was to check browser and such with normal octoprint log in (just because) worked

Next was to get touch UI installed and have it be fullscreen and boot to touch ui
found https://github.com/BillyBlaze/OctoPrint-TouchUI/wiki/Setup:-Boot-to-Browser
Performed git clone https://github.com/BillyBlaze/OctoPrint-TouchUI-autostart.git ~/TouchUI-autostart/

AND sudo ~/TouchUI-autostart/helpers/install success!
followed on screen instructions for above to allow auto log in and it works how I was imagining now. worked

Thanks again to @OutsourcedGuru for that script link as i wouldnt have been able to get it done without that. Not sure why the one that was displayed on the CLI didnt work but maybe something was wrong with it or i was typing it wrong, not sure, whatever the case, thank you again

So now i just need to do a on screen keyboard for login purposes and then it should be all set

Devices used in build were:
Canakit Pi 3b+ 32GB kit
PI 7 inch Touch Screen
Logitech C920 webcam

1 Like

Glad to hear that this worked out for you. Like you noticed, you just needed to keep hacking away at the problem (with a small amount of guidance in the right direction). I was busy doing the Christmas thing and you got a lot of traction over the break. :slight_smile:

I never recommend that, to be honest. I run a Conky interface on my printer's Raspi to watch the performance and you'll be glad that you didn't. The four cores of the Raspi 3 will ensure a good overall experience in browser response, webcam streaming, timelapse as well as streaming all this to the printer. The X windows Desktop that you just added is a bit heavy in processing power as well as a local browser on the Raspi that runs all the time. That's enough for one Raspi 3, in my humble opinion.

I hate to revive a zombie topic. But I have this exact same issue. Actually, I have done everything listed here, I think.

Right now, the Pi boots up and asks for a password, I put in the default and it boots up to the Pixel desktop? I'm kinda lost. Is there a log I can post, or something?

I might just rewrite the SD card and start from scratch, but I'd rather avoid that. Thanks.

Try sudo raspi-config and select the bootup option to log in automatically as pi to the Desktop.

Yes, I knew that but I just wondered if there was anything from OP that modified the initial boot. I did get it squared away finally with a reinstall of everything and sudo raspi-config.

Thank you for your help.

1 Like

if you need to Rotate the Display for power or printer cords fit better you can

sudo nano /boot/config.txt


lcd_rotate=2 to the bottom of the config file.

Hit Ctl+O to save the file. Ctl+X to exit Nano.

In the case of the Adafruit TFT screens, it was necessary to add the (console-based) screen rotation into the dtoverlay command itself in config.txt: github issue. (Rotating the screen display doesn't rotate the touch input device as well.)

hello jdufresne1, I am David ( retired and in Melbourne Australia) and having issue with SD card connection on my i3 (mostly does not work, even after "deoxit").
OctoPrint "seems" to be an obvious choice, but the documentation says that is a server, and needs a network connection that you control from PC.
I have been trying to follow your steps (I have the exact same hardware, complete with the smarti pi stand), but am getting lost.
I have some "tinkering" experience, but do not usually understand, anything linux.
I installed octoprint to the Pi, and can see the octoprint on my network. I have a mainboard, and simulated driving the motors, so it works.
But to get a network connection to my garage, and really want a similar setup to yours. Just to have a small computer (with screen) at the printer, to control it, and use USB stick for the print files.
I do not where I was up to, but it does not goto the desktop.
Do you have process step by guide on how you achieved a successful outcome. many thanks, and regards, David