Unable to disable Discovery module

I'd prefer not to have octoprint broadcasting upnp so I tried disabling the 'Discovery' module from the Plugin Manager but after a restart it's always re-enabled. I've also tried doing the same with the announcement module with the same result. How can I disable it permanently? For reference octoprint is installed on a raspberry pi.

I can't reproduce this here - it stays disabled for me once I restart, on any of the bundled plugins.

Yep, this is working for me fine as well. @Zach_Brown you may want to force a refresh of your browser and probably test in safe mode as well to rule out any plugin related issues.