Unable to login to Debian UI on my PI4

I am a Windows man so go gently when I talk Unix, please.
I am running Octopi 18 on a PI4. I am controlling an Ender 3 Pro. Latest Octoprint on Win 10.
It all works perfectly - I should have left well alone!! But I didn't.
I logged onto the PI using login ID "pi" and my password.
I ran the command sudo raspi-config as advised on a video I found.
It offered me the option to have the PI boot up with a full-screen user interface.
I took the option and it went away and did all its Unix package things. Looked fine.
I rebooted and up popped a full screen Debian invitation to login.
I used the ID "pi" and my password.
It cleared the screen and had a short think and then returned to the same screen asking again for my ID and password.
If I use a wrong password, it tells me immediately that it's wrong.
Octoprint is working fine.
Would really appreciate some advice to get logged in.

The desktop is not installed by default, since it is not required for standard use.

Install it using sudo ~/scripts/install-desktop

Thank you but I assumed that taking the option I described in raspi-config would install the desktop. It did appear to do so.
Either way how do I get back to a command prompt to enter the command you suggest?
Debian is sitting with a full desktop UI waiting for me to login.

Not entirely sure, but you probably want to do it via SSH - since it won't be able to show you any form of desktop there?

AH! of course. I used PUTTY and got into a command prompt.
I ran the command you suggested but I got warnings that if I proceeded, it could cause problems and is not supported in the context of Octoprint.
So, I'm out of here. I'll live with Putty if I need command access.
Thank you for your interest'

1 Like

If you set up the desktop with raspi-config it always seems to do that. Raspberry pi foundation needs to fix that. You'll need to reflash the card, then run the script noted above to properly set up the desktop. Yes, it gives you warnings, but it all still works