Update of Octoprint failed, cant restart service

What is the problem?

Today i saw the announcement for update to Octoprint 1.4.1 and I started the update unintentionally.
In the end the update failed and now i cannot get Octoprint running again.
How can I get the Server running again without loosing all my setting etc.?

What did you already try to solve it?

WinSCP into the pi to get the Log files but dont know how to continue.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)

plugin_softwareupdate_console.log (72 KB)

octoprint.log (22.7 KB)

I did as you said, but the file content still looks same to me.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


That doesn't look like the full log files, only the top of it, which makes sense since you used more.

To get WinSCP to allow you to navigate to ~/.octoprint, you either have to make it display hidden files:

or explicitly enter the location to go to:

Then share the full file please.

I have updated the files above but they look still same to me.

I don't see any difference either, but they also still look truncated/incomplete.

octoprint.log doesn't show you starting the update, let alone an attempt to restart after. plugin_softwareupdate_console.log just ends in the middle of a sentence:

2020-08-04 16:04:03,363 > Looking in ind

but shows that OctoPrint itself should have been update just fine.

What happens if you do the following:

  • ssh into OctoPi
  • sudo service octoprint stop
  • ~/oprint/bin/octoprint serve --debug

The latter should start OctoPrint manually. I would expect it to print some error. In any case, share what gets printed to the screen.

Strange it says Octoprint Version: unknown
No message for manual start

Since your logs are borked I have no idea WHAT happened here (if you are in the habit of pulling power from your Pi without proper shutdown first - stop doing that, it can cause file system corruption that can lead to issues like this one), but we can try one last thing:

  • ssh into OctoPi
  • ~/oprint/bin/pip install --force-reinstall OctoPrint==1.4.1
  • sudo service octoprint restart

That'll reinstall OctoPrint and try to start the service again.

OK, I will try that. My pi is never unplugged, so this cannot be the case.

This is my whole logs Folder. Any other file that would help?

I'm new to the community but I wanted to jump in here. Thank you for everything that you do.

I am having the same problems as @reipet, and the issues started immediately after I updated by agreeing to the auto-update notification. I see nothing in the Octoprint.log file from today's date, and I have deleted the octoprint.log file to see if anything is added on a restart. Nothing even gets written to the log file when I try to launch Octoprint.

The service status shows a status of "exited", and I also used your suggestion above of ~/oprint/bin/octoprint serve --debug, but that returns nothing at the prompt.

pi@octopi:~ $ sudo service octoprint status
? octoprint.service - LSB: OctoPrint daemon
   Loaded: loaded (/etc/init.d/octoprint; generated; vendor preset: enabled)
   Active: active (exited) since Wed 2020-08-05 15:54:54 BST; 3s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 10955 ExecStop=/etc/init.d/octoprint stop (code=exited, status=0/SUCCESS)
  Process: 11099 ExecStart=/etc/init.d/octoprint start (code=exited, status=0/SUCCESS)

Aug 05 15:54:54 octopi systemd[1]: Starting LSB: OctoPrint daemon...
Aug 05 15:54:54 octopi octoprint[11099]: Starting OctoPrint Daemon: OctoPrint.
Aug 05 15:54:54 octopi systemd[1]: Started LSB: OctoPrint daemon.

The webpage on the pi, after a very long wait, shows the following:

I shall try your other suggestion of ~/oprint/bin/pip install --force-reinstall OctoPrint==1.4.1 and report back with an update.


install.log (25.8 KB)

Look at this log I just copied out. Firstly it installs everything, then uninstall everything again.

pi@ender5:~ $ sudo service octoprint status
● octoprint.service - LSB: OctoPrint daemon
   Loaded: loaded (/etc/init.d/octoprint; generated)
   Active: active (running) since Wed 2020-08-05 17:12:05 CEST; 3min 30s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 930 ExecStart=/etc/init.d/octoprint start (code=exited, status=0/SUCCESS)
    Tasks: 26 (limit: 1944)
   CGroup: /system.slice/octoprint.service
           └─936 /home/pi/oprint/bin/python2 /home/pi/oprint/bin/octoprint serve --host= --port=5000

Aug 05 17:12:05 ender5 systemd[1]: Starting LSB: OctoPrint daemon...
Aug 05 17:12:05 ender5 octoprint[930]: Starting OctoPrint Daemon: OctoPrint.
Aug 05 17:12:05 ender5 systemd[1]: Started LSB: OctoPrint daemon.

Reporting back at promised... Something VERY odd is going on. :frowning:

I tried running ~/oprint/bin/pip install --force-reinstall OctoPrint==1.4.1 and it reports as follows:

pi@octopi:~ $ ~/oprint/bin/pip install --force-reinstall OctoPrint==1.4.1
Requirement already satisfied: OctoPrint==1.4.1 in ./oprint/lib/python2.7/site-packages
You are using pip version 9.0.3, however version 20.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.

I thought it was a bit odd that pip was so out of date, so I tried to update it only to find that pip was not installed. That seemed very unlikely, so I reinstalled it, but sadly I still can't start Octoprint.

Please let me know if I can capture any more information that will help.

Kind regards,

Now I have Octoprint running again.
After reinstalling I rebooted the whole pi and now I can login again normally.
Many thanks for your help.

I had the same pip message. I think you can ignore it. Tried restart the Pi after reinstall?

As note, I had the same issues and came to see if there were other posts. Would have provided near-carbon-copy info as Q-Branch above.

However, performing the SSH update method and restarting the server worked and everything looks good. It booted in safe mood first, but now all seems well.

Thanks. I have tried a re-install and a reboot, and sadly mine is still dead in the water.

It's still reporting that the service exited. I shall try deleting it altogether and starting again.


Well that was a bit of a mess, but I got there in the end. :face_with_thermometer:

I had to resort to nuking octoprint completely, deleting its installation directory, and then re-installing everything octoprint-related on the Raspberry Pi from scratch. If anyone is in a similar position, then I suggest following the "Basic Setup" and "Automatic start up" sections of the following page:

I have lost all of my recent configuration, which is obviously my own fault for not having a backup that was more recent than January 2019. I'm starting again, with my head hanging in shame.

Thank you to @reipet and others for their quick responses, and of course to @foosel for her magnificent software. I strongly recommend that more people contribute to the development effort on Patreon - https://www.patreon.com/foosel/ (and no, I'm not getting anything in return to endorse Gina's stuff. I just like it!)


For future reference, that's the pip of the venv. You would have to use ~/oprint/bin/pip install --update pip to update it, pip is not installed globally on OctoPi.

1 Like

Thank you Charlie. I wasn’t using a venv at the time, but I implemented one when I re-installed. I’ll keep this in mind for the future.

1 Like