Updating from 1.3.10 to 1.3.11 through web interface broke octoprint

#41

You should paste the error.

#42

We might deduce from this that your original OctoPi instance wasn't 0.16.0 (with underlying Raspbian Nov 2018) but more probably 0.15.1 or earlier (with Raspbian Jun 2018). It would be great to know any errors you saw (if any) during that earlier upgrade attempt.

#43

Hello,

I'm on windows and I got the same problem while udpdating. I don't remember the previous version unfortunately. Here is the log :

C:\OctoPrint\venv\Scripts\octoprint.exe serve --port 5005
Traceback (most recent call last):
File "C:\OctoPrint\venv\Scripts\octoprint-script.py", line 6, in
from pkg_resources import load_entry_point
File "c:\octoprint\venv\lib\site-packages\pkg_resources_init_.py", line 309
8, in
@call_aside
File "c:\octoprint\venv\lib\site-packages\pkg_resources_init
.py", line 308
2, in call_aside
f(*args, **kwargs)
File "c:\octoprint\venv\lib\site-packages\pkg_resources_init
.py", line 311
1, in _initialize_master_working_set
working_set = WorkingSet.build_master()
File "c:\octoprint\venv\lib\site-packages\pkg_resources_init
.py", line 575
, in _build_master
return cls.build_from_requirements(requires)
File "c:\octoprint\venv\lib\site-packages\pkg_resources_init
.py", line 588
, in build_from_requirements
dists = ws.resolve(reqs, Environment())
File "c:\octoprint\venv\lib\site-packages\pkg_resources_init
.py", line 777
, in resolve
raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'watchdog<0.9,>=0.8.3' distribution was
not found and is required by OctoPrint

My problem is that I don't know how to force reinstall under windows. And I don't want to lose my whole configuration.

#44

I note that you don't appear to be running this under the control of virtualenv; I'm used to seeing a command prompt which demonstrates that you earlier ran something like source venv/bin/activate.

If you've not done that then python/pip will be using a more global set of modules and executables instead of the OctoPrint-controlled virtual environment. In this controlled one, the watchdog piece of all this might be the correct version for all we know.

#45

I had the same issue. After trying every suggested step here in the topic, i tried to just reinstall every package and after this the update to 1.3.11 worked like charm.

These were the steps I took:

dpkg --get-selections | grep -v deinstall | awk '{print $1}' > list.log
awk '$1=$1' ORS=' ' list.log > newlist.log
sudo apt-get install --reinstall $(cat newlist.log)
~/oprint/bin/pip install --no-cache-dir https://get.octoprint.org/latest
sudo service octoprint restart

It is not the most filigree solution, but rather the steam hammer, but now everything is running again.

1 Like