Upgrade to 0.18 and 1.7.0rc1 bumps

I had a few road bumps in upgrading from 0.17 to 0.18 octopi and 1.6? to 1.7.0rc1 octoprint along with the 0.18 upgrade. Where would this feed back be most useful?

With the release candidate. Is there a specific forum for feedback (and possible problems, which I am sure I won't run into :slight_smile: )

Thanks, Don

1 Like

There's a general feedback ticket here, but for any actual bugs we ask that you open a separate bug report.

It helps to have all the feedback in one place, but don't hesitate to post something, we can share it in the right places.

OK, thanks, and yes I am using 1.7.0rc1. I've only made one print, but that went well :+1:

The things I noticed were this. I backed up my octoprint then downloaded and installed 1.7.0rc1 and as expected was prompted to upgrade to python3. Found the FAQ to install 0.18 to get Python3. I downloaded the Raspberry Pi Imager and and followed the update instructions on the site. When I ran the imager I used Shift-Ctl-X first to set the WPA SSID and passphrase. While there I enabled SSH. Then used the procedure to burn 0.18 to a card.

This all went fine. When I put the card in the Pi and booted it seemed ok until I tried to connect (I use Putty on Windows). No connection via IP address. I looked in the management interface of my router and I saw a new device on an odd IP address in the connected devices list. I have a DHCP address reservation for OctoPi and that address did not appear.

So, I figured I mucked something up in the Imager and started over. The odd thing I found was when I used Shift-Ctrl-X the preshared wifi key, which has an ampersand (&) in it and the string displayed was 'xxxxxx;amp&xxxxxx' with the ';amp' inserted as I didn't enter it. So I went into the router and changed the PSK to a simple combination of dictionary words and entered this into the Shift-Ctrl-X interface and wrote the image to the card. Booted the Pi with the new imaged and all worked well. Picked up the reserved DHCP address from the router so I used SSH to connect to the OctoPi and used raspi-config to reconfigure the PSK and got everything back the way it was.

When I tried to install the 1.7.0rc1 backup got an error message that the backup was a newer version that what was installed (1.5.x I think in the Pi Imager program?) So I upgraded to 1.7.0rc1 and then was able to restore my original backup.

After this little hiccup all worked well.

Thanks, Don

1 Like

Sounds like there might actually be a bug in the rpi-imager then, if it mangles wifi credentials like this. My money would be on it doing that regardless of which image you flash, OctoPrint/OctoPi unrelated, as that config dialog is generic and not image specific. You might want to raise that issue in their repo.

The "backup version mismatch" is intentional - applying a back from 1.6.x on 1.6.y will work, but not a backup from 1.7.x. Otherwise I'd open a can of worms with regards to compatibility. I've actually set something up that will prep up to date OctoPi images in the future, just tested this out yesterday for the first time and am looking into making it the default in the rpi imager once it proves stable, and that should hopefully make this less of a hassle in the future, as will the "update OctoPrint" as first step in the setup wizard that's been added for 1.7.0.

Which version of RPi imager are you using? V1.6 I know struggles with special characters in WiFi passwords, and in either 1.6.1 or 1.6.2 they have changed the behaviour so that the script that enters the WiFi credentials actually contains a hash of the password, which apparently makes it easier to support the special characters - might be something worth checking, otherwise it is a bug that can be reported.

Edited: just read it again - actually sounds like this might have been in the UI, so not covered by the changes above.

@Charlie_Powell RPi version is 1.6.2.

@foosel Yes, I believe it is a bug in rpi-imager. You are right, the problem is independent of the OS chosen in the imager.I have several 'special characters' along with digits and alpha in my PSK. Only the & was changed to the &;amp characters. I guess I was just looking at my post as a heads up to someone who might stumble across the same issue. The solution (simple text phrase for PSK) was quite easy to implement and then changing back after install was just as easy :slight_smile: I will post in the rpi-imager repo.

Any I get that trying to keep the imager up to date with current/rc version could be a nightmare, again, more for someone else having the same issue. Believe me I have traversed similar minefields my self many, many times.

Thanks again for a great system that is very impressive and I hope to be able to 'give back' with the RC.


Gina's working on something for that :slightly_smiling_face: - it's in testing through the 1.7.0 RC stage, then hopefully all automated for future releases, so the RPi imager is automatically updated with the newest OctoPi release.